Cant get FXS on SPA3102 to register after BindPort change

I changed my bindport to, for example, 9500, SIP Settings

I then changed my extensions ports in FreePBX to be 9500 as well.

I then changed my phone configurations to register to 9500.My phones register

I also changed my SPA3102 Line 1 extension to 9500, but the FXS extension will not register! I

I even factory reset. Also tried changing port in FreePBX to 5060 and setting back to 5060 on SIP Line 1, no luck.

Any ideas :frowning:

http://www.freepbx.org/support/documentation/howtos/howto-linksys-spa-3102-sipura-spa-3000-freepbx

It is one of those old linksys things I told you about elsewhere

That guide is for how to configure the FXO port which Ive read many times, and have successfully configured the FXO port before, but this time I’m only using the SPA3102 for the FXS port

This is the config page for the FXS port
http://www.freepbx.org/support/documentation/howtos/how-to-set-up-a-linksys-pap2-or-sipura-spa-2000-for-use-with-freepbx

Ive followed it. but no registration.

It was registered before the bindport change and now is not … even though I changed the freepbx extension settings to match bindport and changed the line settings to same port on spa3102 fxs

SPA3102 FXS extension still will not register!

Keep in mind this is just a simple extension registration because it is FXS, there is no trunk settings involved.

When the FXS SPA3102 extension is called, it does not ring and the caller hears “busy tone”

You will need to fix that “unavailable” on that extension, there are endless posts out there on how to make them work, you need to be more resourceful (I don’t believe they can handle TCP connections, I might be wrong . . . .) :slight_smile:

Okay check this out!

I got wireshark on the SPA3102 to see what the hell its doing, and heres what I found out:

  • SPA3102 sends REGISTER to freepbx on port 5060
  • FreePBX responds “no ones home” because it is listening for SIP on 9901 for example

When I change the SIP port settings of the FXS extension, what it really does is it still sends on 5060 instead of 9901, but says “hit me back at 9901”

ANYONE KNOW HOW I CAN FIX THIS!

Besides Dicko because hes already spent like the last 14 hours helping me today lol

Thanks

I’m trying on UDP not TCP. I used TCP for my remote cell pphone app ZoIPER

That would be easy, change the port that the 3102 is using to register on. (it’s in all the FM’s and in the 3102 http setup pages , you REALLY need to read and absorb that stuff :wink: )

I have it set to the right port in the HTTP, but its still trying to talk to freepbx on 5060

I don’t have that problem, don’t forget there are two SIP interfaces on that device FXO and FXS and they can’t both use the same port ( I told you that before) did you reboot the f*^*er?

Yeah the FXO is disabled, but if it was enabled its supposed to be 5160…

Product Name: SPA-3102 Serial Number: CF600MC05155
Software Version: 5.2.13(GW002) Hardware Version: 1.4.5(a)
MAC Address: 0xxxxxxxxxx Client Certificate: Installed
Customization: Open

Can you let me know what firmware your using? And you also have the same setup - your using a custom bindport? and it works?

Rebooted, still sends on 5060 and in the header it has the custom port instead… I even have another SPA3102 and it does the same thing

ITS COMING FROM THE CUSTOM SIP PORT INSTEAD OF SENDING TO IT! wtf :\

Sorry I haven’t actively set one up in a while, but the ones I have just work on non standard ports , it’s just my old befuddled memory of fighting with them, maybe someone else can step in . . . .

I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!
I DID IT!

I made the FXS ring!

dicko,
IT WAS THE PROXY SETTING ON THE SPA

To make it register:
I set to 192.168.9.204:9901 (FreePBX-LAN-IP:FreePBX-BindPort)

WORKS

Big thank you for your dedication to helping me with this insanity.

Its funny because it was the same thing I did to fix ZoIPER, add the port after the IP in the proxy address…

Honestly, if you werent such a dick about it, I probably wouldve given up and never figured it out :wink: lol so thanks for basically calling me a newb and pissing me off. It was the determination that I needed!

It’s always better to learn to fish than to want another man’s fish for his dinner :slight_smile: , I’m gratified that you persevered.