Can't Fresh Install

For the life of me I can’t get a fresh install of Freepbx distro to finish. I’m installing via flash drive and it boots to the drive ok and gets mostly through the install and fails every time. I’ve tried it with and without a network connection, I’ve tried multiple computers, and I’ve tried multiple versions of freepbx installers. I’ve also tried multiple flash drives and multiple image writer programs. What in the heck am I doing wrong?

I’ve tried the standard recommended install settings, different versions of asterisk, freepbx versions 14, 15 and 16.

I’ve tried the following versions:
STABLE SNG7-PBX-64bit-2104-1

Attached is a picture of what the error looks like.

You will need a “working” network. If you can guarantee that, then :-

On what hardware are installing ?
Have you checked to md5sum’s of the downloaded media against the published ones?

I’ve tried it on a 4th gen i5 laptop with 8GB of RAM and a 480GB SSD, and a 2nd gen i5 desktop with 8GB of ram and a 480GB SSD. Yes, the checksums work fine, and one of the installers is one I still had in my download folder from 2018 when I last successfully used it.

I’m positive my network is working.

My guess is that your network hardware is not supported by the install kernel for your i5’s .
You can change the console tty (ALT-CTL-F{1-7} or as the screen suggests, press the ‘debug’ button for tty1 ) to check errors and try to ping something , maybe consider using an usb/eth adapter to get you past this, then install a .ko for your intel/broadcom eth hardware.

I tried four different USB adapters. Two 10/100 usb 2.0 and two gigabit usb 3, each was a different model. All of them showed a valid connection.

By a ‘valid connection’ , do you mean you could successfully ‘ping’ from tty1 which shows a Layer3, (IP connection with a valid address, gateway and netmask, presumably awarded by your local DHCP server), or (the ‘link’ led was on, (Layer2, ethernet))?.

Where there any other errors on tty4,5,6 or 7 ?

Other thing to check would be the ‘uefi-ness’ set in the bios.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.