Can't finish freePBX 14 install on centos


(Fizgriz) #1

I cant finish the Freepbx 14 install on my fresh CentOS 7 build. What do i do here?

I get to the last part, and it fails:

[root@voip freepbx]# ./start_asterisk start
**STARTING ASTERISK**
Asterisk Started**
[root@voip freepbx]# ./install -n
Assuming you are Database Root
Checking if SELinux is enabled...Its not (good)!
Reading /etc/asterisk/asterisk.conf...Done
Checking if Asterisk is running and we can talk to it as the 'asterisk' user...Error!

Error communicating with Asterisk. Ensure that Asterisk is properly installed and running as the asterisk user
Asterisk appears to be running as asterisk
Try starting Asterisk with the ‘./start_asterisk start’ command in this directory

All directorys owned by asterisk:asterisk

/var/run/asterisk
/etc/asterisk
/var/{lib,log,spool}/asterisk
/usr/lib64/asterisk
/var/www/

ps -aux |grep asterisk
root       815  0.0  0.0 113292   924 pts/0    S    19:59   0:00 /bin/sh /usr/sbin/safe_asterisk -U asterisk -G asterisk
root      1502  0.0  0.0 113292   916 pts/0    S    20:02   0:00 /bin/sh /usr/sbin/safe_asterisk -U asterisk -G asterisk
root      1952  0.0  0.0 112812   972 pts/0    R+   20:02   0:00 grep --color=auto asterisk
asterisk 57593  0.0  0.2 582144  9344 ?        S    19:32   0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 57594  0.0  0.2 582144  9344 ?        S    19:32   0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 57595  0.0  0.2 582144  9344 ?        S    19:32   0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 57596  0.0  0.2 582144  9344 ?        S    19:32   0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 57597  0.0  0.2 582144  9344 ?        S    19:32   0:00 /usr/sbin/httpd -DFOREGROUND

asterisk seems to always start as root? I’ve modified:

/etc/asterisk/asterisk.conf
/etc/init.d/asterisk
/etc/default/asterisk

[root@voip freepbx]# ls -alh /home/asterisk
total 16K
drwx------  4 asterisk asterisk 112 Apr 12 19:36 .
drwxr-xr-x. 3 root     root      22 Apr 12 18:23 ..
-rw-------  1 asterisk asterisk 134 Apr 12 20:04 .bash_history
-rw-r--r--  1 asterisk asterisk  18 Mar 31  2020 .bash_logout
-rw-r--r--  1 asterisk asterisk 193 Mar 31  2020 .bash_profile
-rw-r--r--  1 asterisk asterisk 231 Mar 31  2020 .bashrc
drwxrwxr-x  3 asterisk asterisk  18 Apr 12 19:35 .cache
drwxrwxr-x  3 asterisk asterisk  18 Apr 12 19:35 .config

#2

You have been told dozens of time to either use the g’damned Distro or RTFM’s!


(Fizgriz) #3

I have been told? This is my first post here? I did read the manual. I used this guide completely:
https://wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+CentOS+7


#4

This might be the first post @fizgriz has made here, I don’t think many here believe it is YOUR first post.

Ma grand-mère m’a longtemps dit d’aller, si quelque chose marche comme un canard, parle comme un canard et défèque comme un canard, c’est probablement un canard.

We already told @fizgig10


(Fizgriz) #5

what? Are you here to help or spout crazy theories of someone you have never met online asking for help on the forum for helping people with this product?

I’ve never posted a question on this forum ever. I legit can’t tell if your serious or just a troll.


(Fizgriz) #6

I have no relation to a user named fizgig10. The ‘fiz’ is purely coincidental…


#7

If you say so, he had exactly the same problems as you a couple of weeks ago, Coincidence? Perhaps.

Try over with a distro.


(Fizgriz) #8

This is my first post ever. First account ever. I’ve never been on this forum ever before this point. You legit sound insane and like you have some grudge against someone that shares the first part of ‘fiz’ in the name.

‘fiz’ is common in usernames…

I legit just started this project today… and i came to the forums of the product asking for help.


#9

You’ve come a long way in a day so you are probably a quick learner, but not nearly enough yet, there is a link at the top of the page to the Wiki, spend tomorrow there and like most folks you will be up and running on Wednesday.

This is the same advice given to every newbie.


(Greg Snover) #10

I’m a little curious - Why are you loading 14 instead of 15? Wouldn’t it be easier to use the Current - no criticism, just a question.

Dicko is actually quite helpful - you just had the misfortune of giving him a Vietnam-Flashback! :wink:


(Fizgriz) #11

Gsnover,

Thank you for the reply. I honestly thought that the freepbx 15 was a distro iso only.

This is for a very strict regulated environment, and I needed a source link to try and install it manually. I’ll have to go through separate channels for approval for an distro iso install instead of a source install on a box that can be more controlled. I was trying to following the install guide, and luckily this is on a VM and tried 3 times with the same result on the install. I couldn’t figure out what i was doing wrong, and I came here hoping it was an easy fix or miss.


#12

Either way, can I suggest you forgot the


make
make install
make config
ldconfig
chkconfig asterisk off

step in your recipe?

The pertinent point is

chkconfig asterisk off

safe-asterisk will fight with how FreePBX wants to do things. (and you have two instances running, which is kind of bizarre)


(Greg Snover) #13

FreePBX is a VERY complicated “Stack” of services/components to get installed correctly - Hence Dicko’s suggestion to use the Distro - I also have tried (in the distant past) to get it working on a scratch install of CentOS - I think it was 11 or 12 - I got it working, but so many things are just baked into the distro that it was not worth it (to me at least) to run it that way.

Having said that, Sangoma/Digium (one and the same now…) is a well-established offering with commercial alternatives - you are setting a high bar for yourself if you have never used it before to get it running “naked”.

It’s possible, just really not easy.


(Fizgriz) #14

I completed all those steps. I thought the same thing so on my second attempt i made sure to follow those.

Would including an unneeded application in make menuselect, cause asterisk to fail?


#15

No, just make sure you have res-macro select.

killall safe-asterisk’s before attempting the install with start-asterisk or restart the machine after disabling the asterisk server.


(Fizgriz) #16

In case i cant figure out the source install. Can the distro be safely installed as a VM on hyper-v? Is it CentOS 7 based?


(Greg Snover) #17

Yes - Almost all my PBX’s are Hyper-V Hosted VM’s - It works great.