Can't enble WebRTC Phone for UCP

Good morning,

I just installed FreePBX 16 on Debian, my goal is to enable WebRTC Phone in UCP, I’ve installed all the packages and created an user that can access UCP interface (in user setting “Phone” is setted to “Yes”), I’ve setted a certificate with Let’s Encrypt and still I can’t see the phone icon in the “Add Widget” UCP panel.

Am I missing something here?
Thanks in advance for the help!

Do you see any errors in the asterisk logs or while watching asterisk -vvvvvr when you open UCP? Only other thing I can think of is to make sure wss transport is enabled in Settings > Asterisk SIP setting > chan_pjsip and then maybe try fwconsole restart.

The other thing to try is force websocket mode to pjsip in Settings > Advanced Settings after enabling Display Readonly and Override Readonly Settings. You should still see the phone icon even if that’s a problem though, it would just be yellow instead of green.

Thank you for the response but no…
no errors (neither in logs or in asterisk terminal), I also tried your fix but nothing changed

Still having this issue, someone know how to fix?

Hi @Lorenzo
Have you enabled FreePBX and UCP to use your LE Cert? Also you need to enable from FreePBX and Edge Firewall HTTPS and WEBRTC ports too.

Check this wiki pls.

Hi @shahin,

thank you for your reply, I followed the links but they seems to be an old layout(?) (I worked with some FreePBX in the past and It seems like the old layout).

I have the phone enabled in “user management” but nothing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.