Can't dial out or ext to ext but can recieve calls

ok, I am a noob and I think I may have read every post trying to figure this out with no resolve.

we have bandwidth.com as our provider but not through freepbx because I ordered the trunks first and didnt know about the module.

our setup:

free pbx 2.8.1.4
phones: Cisco spa 303
Trunks: bandwidth.com

After reading a gazillion posts I have gotten the inbound calls to stop dropping and sound clear. (no nat and codec g729 issue) Thanks for those posts.

I have gotten endpoint manager to recognize the phones and program them ( had to install every version until I got one to work 2.10.3.6 works on 2.8 so far no prob i think lol.) Also you have to enable the phone/model in endpoint configuration as well as add the mac to the oui…

Sorry if I have forgotten anything as

  1. I am new to unix
  2. I am new to freepbx
  3. I am a little frustrated

I appreciate any help from anyone.

(I actually forgot to write the challenge at hand, lol smh)

I have done asterisk -rvvvvvv and when dialing from the phone all it says is this:

– Remote UNIX connection
– Remote UNIX connection disconnected

When I dial the lcd reads “invalid number” and through the handset you hear a busy signal.

  • Name : 4101
    Secret :
    MD5Secret :
    Remote Secret:
    Context : from-internal
    Subscr.Cont. :
    Language :
    AMA flags : Unknown
    Transfer mode: open
    CallingPres : Presentation Allowed, Not Screened
    Callgroup :
    Pickupgroup :
    MOH Suggest :
    Mailbox : [email protected]
    VM Extension : *97
    LastMsgsSent : 32767/65535
    Call limit : 2147483647
    Max forwards : 0
    Dynamic : Yes
    Callerid : “device” <4101>
    MaxCallBR : 384 kbps
    Expire : 2122
    Insecure : no
    Force rport : No
    ACL : Yes
    DirectMedACL : No
    T.38 support : No
    T.38 EC mode : Unknown
    T.38 MaxDtgrm: -1
    DirectMedia : No
    PromiscRedir : No
    User=Phone : No
    Video Support: No
    Text Support : No
    Ign SDP ver : No
    Trust RPID : No
    Send RPID : No
    Subscriptions: Yes
    Overlap dial : Yes
    DTMFmode : rfc2833
    Timer T1 : 500
    Timer B : 32000
    ToHost :
    Addr->IP : 192.168.1.239:5060
    Defaddr->IP : (null)
    Prim.Transp. : UDP
    Allowed.Trsp : UDP
    Def. Username: 4101
    SIP Options : (none)
    Codecs : 0x104 (ulaw|g729)
    Codec Order : (ulaw:20,g729:20)
    Auto-Framing : No
    100 on REG : No
    Status : OK (9 ms)
    Useragent : Cisco/SPA303-7.4.9c
    Reg. Contact : sip:[email protected]:5060
    Qualify Freq : 60000 ms
    Sess-Timers : Accept
    Sess-Refresh : uas
    Sess-Expires : 1800 secs
    Min-Sess : 90 secs
    RTP Engine : asterisk
    Parkinglot :
    Use Reason : No
    Encryption : No

It’s registered must be a dial plan issue

It’s registered must be a dial plan issue

And that dialplan error might be either on the phone or on your “FreePBX”

Global Settings:

UDP Bindaddress: 0.0.0.0:5060
TCP SIP Bindaddress: Disabled
TLS SIP Bindaddress: Disabled
Videosupport: No
Textsupport: No
Ignore SDP sess. ver.: No
AutoCreate Peer: No
Match Auth Username: No
Allow unknown access: Yes
Allow subscriptions: Yes
Allow overlap dialing: Yes
Allow promisc. redir: No
Enable call counters: No
SIP domain support: No
Realm. auth: No
Our auth realm asterisk
Use domains as realms: No
Call to non-local dom.: Yes
URI user is phone no: No
Always auth rejects: Yes
Direct RTP setup: No
User Agent: FPBX-2.8.1(1.8.7.0)
SDP Session Name: Asterisk PBX 1.8.7.0
SDP Owner Name: root
Reg. context: (not set)
Regexten on Qualify: No
Legacy userfield parse: No
Caller ID: Unknown
From: Domain:
Record SIP history: Off
Call Events: Off
Auth. Failure Events: Off
T.38 support: No
T.38 EC mode: Unknown
T.38 MaxDtgrm: -1
SIP realtime: Disabled
Qualify Freq : 60000 ms
Q.850 Reason header: No
Store SIP_CAUSE: No

Network QoS Settings:

IP ToS SIP: CS3
IP ToS RTP audio: EF
IP ToS RTP video: AF41
IP ToS RTP text: CS0
802.1p CoS SIP: 4
802.1p CoS RTP audio: 5
802.1p CoS RTP video: 6
802.1p CoS RTP text: 5
Jitterbuffer enabled: No

Network Settings:

SIP address remapping: Disabled, no localnet list
Externhost:
Externaddr: (null)
Externrefresh: 10

Global Signalling Settings:

Codecs: 0xe (gsm|ulaw|alaw)
Codec Order: ulaw:20,alaw:20,gsm:20
Relax DTMF: No
RFC2833 Compensation: No
Symmetric RTP: No
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 0 (Disabled)
RTP Hold Timeout: 0 (Disabled)
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: Yes
Pedantic SIP support: Yes
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Notify ringing state: Yes
Include CID: No
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No
Outb. proxy:
Session Timers: Accept
Session Refresher: uas
Session Expires: 1800 secs
Session Min-SE: 90 secs
Timer T1: 500
Timer T1 minimum: 100
Timer B: 32000
No premature media: Yes
Max forwards: 70

Default Settings:

Allowed transports: UDP
Outbound transport: UDP
Context: from-sip-external
Force rport: No
DTMF: rfc2833
Qualify: 0
Use ClientCode: No
Progress inband: Never
Language:
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: *97

So if I have no trunks and no routes I should be able to dial from extension to extension right?

If I remove all of the trunks and routes and I can’t call extension to extension, its in the phone?

I don’t think it has anything to do with the dial plan, because I’m in a similar situation. The dial plan matches the default SPA303 factory settings. I cannot dial out to any number, though the phone worked without issue if it was manually provisioned (not with endpoint manager).

I just verified that manually configuring the phone results in no issues dialing in or out. It is related to the xml config that is posted for the SPA303

I also had a similar problem in setting up my Cisco SPA 303s using Endpoint manager. I was able to receive calls, but not make them from the phone. I accidentally discovered that if I gave the phone a Station name in the Endpoint manager (edit custom template of the phone) reboot, then the phone suddenly worked fine.

Using OSS PBX End Point Manager 2.11.4.11