Can't connect Yealink T41S to PJSIP with TLS

Hi all,

I’m having problems connecting my Yealink phones to FreePBX using PJSIP and TLS. ChanSIP works fine with TLS but my extensions are all pjsip. There is a Comodo SSL Cert installed which has been working fine for secure provisioning/ucp/gui etc. My settings are as follows:

Advanced SIP Settings:
Certificate manager: freepbx cert
SSL method: default
Verify client: no (I have also tried yes with no luck)
Verify server: yes

Transport TLS: yes
Default TLS port assignment: pjsip

On the extension page I have had transport set to auto or tls with no luck and I have restarted asterisk using fwconsole restart. In the phones, TLS is selected on the account settings page along with port 5200. My thoughts were that a firewall could be stopping this, but this phone is on the same LAN as the pbx. I have also tried adding the certificate into trusted certificates and telling the phone to trust all certificates. Any help or advice would be greatly appreciated as I feel I am missing something obvious.

Thanks in advance

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.