Can't complete upgrade to 12

Hi. I manage two FreePBX systems and decided to go ahead and upgrade them from 2.11 to 12. The first went with no problems at all. A few days later, I decided to upgrade the second system. I downloaded the first part, Framework, and when I went back to Modules and clicked started to do all the other upgrades. The first was Core. My current core is 2.11.0.32, and the upgrade path is 12.0.1rc3. Clicking through Process and Confirm gives the message:

Downloading and Installing core
Downloading core
Found module locally, verifying…Redownloading
Error(s) downloading core:
Unable to connect to servers from URLs provided: http://mirror1.freepbx.org/modules/packages/core/core-12.0.1rc3.tgz.gpg,http://mirror2.freepbx.org/modules/packages/core/core-12.0.1rc3.tgz.gpg

So, now I’m stuck. The good news is that the system still processes calls, so that’s good. And menus sorta work, but I’m not making any changes.

So, what happened the folder?

Thanks.

There is no issue with any “folder”. The DNS lookup on your machine is wrong. It can’t connect to the provided URLs.

You can download the file manually yourself: http://mirror1.freepbx.org/modules/packages/core/core-12.0.1rc3.tgz.gpg

To check and make sure its working (I assure you, it is)

But your machine is unable to complete that process due to network issues, something we have no control over.

I appreciate the reassurance. You can imagine my consternation… an upgrade works on one machine and not on a similarly configured one, I even plugged the URL into a web browser on a different computer, and also got the 404. What else was I to think?

If I plug in the URL in the browser on my tablet, here on my home network, I can download the file.

I changed the /etc/resolve.conf on the system to point to known good DNS (208.67.222.222).

Why would ‘Check Online’ resolve properly to find the available upgrades, but not find the actual download itself?

If I go to an SSH session on the PBX and ‘wget’ the URL, it downloads the file just fine. Kinda rules out a network problem.

1 Like

If it works on one machine but not the other don’t you think it’s related to that machine. If it works in your tablet don’t you think it’s that one machine

Look honestly we could go back and forth all night pointing fingers but I’ve got 4000 people that disagree with you not being able to download it

The URL provided by the error above has a comma in it. It’s actually two separate links so if you linked it as “one” then you’d get a 404 (because you are requesting multiple links at the same time). But that is not your problem anyways (and freepbx breaks apart the links anyways)

These download/lookup issues always result in the same thing. It is a system or firewall issue on your end. I am just going based off of what the end result always is and how can you disagree if you see it worked fine on one system you own but not the other. I digress we can go back and forth all night long. When it comes down to it the URL is unresolvable but only for you on one system.

These “issues” are always hard to diagnose. They are completely network related. Running wget on said machine and then saying that rules out a network problem is incorrect. Sure you’ve helped narrow it down but php uses curl not wget (unless you changed it) to download files AND if it’s set to use wget there are parameters attached to it. So you just “running” it manually has no bearing to saying it’s not a network issue. I asked to you run it so that I could determine step one in a list of compounding issues. So bear with me here…

And I’m not going to go into the details here because it’s a waste of time but yes checking online and downloading can have completely different results in the end different code bases and executions. First off one can use curl to get the xml files and the other can use wget. That is one example of many of how downloading works.

When is the last time you checked this? Have you tried again? Are you in wget mode in advanced settings? Do you know what that is? (In freepbx that is)

Aside from that you can also try these commands:

amportal a ma upgrade core

Then

amportal a ma upgradeall

They may just help you

Sorry for the long rant. But I can only assume you originally thought my reply to be something along the lines of “did you check if it’s plugged in?” What I wanted to assure you of was that I didn’t mean it in a negative way, just that these threads almost always resolve themselves as “user” error in the end.

Hi
Ive got the “same” error, i can get the files, but if i do upgrade via the Module Admin i get the same error.
"Unable to connect to servers from URLs provided: hXXp://mirror1.freepbx.org/modules/packages/core/core-12.0.1rc4.tgz.gpg,hXXp://mirror2.freepbx.org/modules/packages/core/core-12.0.1rc4.tgz.gpg"
its the comma, thats the error?
If i try “amportal a ma upgrade core” i get the same thing “hXXp://mirror1.freepbx.org/modules/packages/core/core-12.0.1rc4.tgz.gpg,hXXp://mirror2.freepbx.org/modules/packages/core/core-12.0.1rc4.tgz.gpg”

Ive just upgraded yesterday, so how do i upgrade the core manually or how do i overcome this issue?

What version of centos?

CentOS release 5.7 (Final)

Advanced Settings > “Use wget For Module Admin” > false

1 Like

thanks! works, perfect!

That fixed the problem for me, as well.
Thank you, Andrew.

Just reading through this topic, I checked my Advanced Settings > “Use wget For Module Admin” > false - and it is on false, I have never touched this setting, so is it set to False by default?

Yes. If you are still having issues then it is unrelated to thisnthread

I had the same issue. Have never changed the setting before but changing it to false seems to be allowing the updates which I’m currently applying. Thank you Andrew.

This posted just saved my butt on a old install… Thank you SO MUCH!!