Cant access any of the .conf files

For some reason, either I am doing something wrong or something else, I can not get to the sip.conf or any of the other .conf files that are mentioned in several tutorials. Can anyone tell me how I get to those? Thanks!

Secure shell and VIM or NANO. They are located in /etc/asterisk.

Don’t go editing sip.conf or you’ll be sorry. Sounds like you are looking at a asterisk tutorial and tells you to edit those files…

Please read the top of the files and pay attention to the statements about not editing them…

For more information please see:

see my post

Can’t access conf files.

how about some actual details? you try to look at a conf file and it is missing? permission errors? space aliens swoop down and stop you?


In that you’ve provided almost no details including your skill set we don’t know how to answer without it easly coming out wrong.

Do you know linux and how to move around? If not that is one whole issue.
If so what error are you getting when you do move around and try and edit them?

More important.

Please don’t confuse a tutorial about configuring asterisk as something that you can automatically do once FreePBX is installed. FreePBX replaces many of the default files with advanced files and many includes so that the FreePBX system can own and control what it needs to and yet allow users to edit other things that either FreePBX don’t yet control, or might be an advanced setup option that was just not coded for because only 1 in 1000 users would need it and it’s not worth the time to do it.


You issue is a whole other thing and I’ll address it in your message but you should have figured it out…

rossiv ,

I have a solution. If you can edit some of the conf files, but can not see others such as sip.conf.

Check out the “Problem Solved” at “Can’t access conf files”. It worked for me.