Can't Access Admin Page For FreePBX

I just finished installing free pbx. I just tried to go to the ip address of the server through the web browser and it says it is taking too long to load so try again. I think I installed Free PBX 16. I did it on the page

Has anyone seen this issue? Can anyone help?

If you want help, you need to tell us what is wrong, what you have observed, and what you have already tried.

I assume that you did a manual install because you have an environment (cloud server, container, non-Intel platform, etc.) where it’s difficult or impossible to run the Distro. Please describe that, or explain why you didn’t just install the Distro.

Can you access FreePBX by ssh? If not, what access do you have (console, etc.) and what does it show you about networking?

If httpd running? If not, do you get any errors when you try to start it, or do any get written to apache or system logs?

If FreePBX is running a firewall, have you tried disabling that?

If there is a hardware firewall between you and the FreePBX machine, are you sure that it is passing HTTP?

If running on a virtual machine where you also control the host, have you set up bridged networking? If not, please explain.

I have a dedicated server with full root access. I am pretty sure the processor is intel. I have cent os 7.

I looked it up on Google how to install asterisk and then how to install freepbx. I can show you what tutorials I used so you know what I did. I did upgrade php to 5.6.

I have ssh access. I already got rid of the errors that happened when installing freepbx. I had to change the user asterisk was running as from root to asterisk.

I already created the asterisk user so the apache server is running as asterisk. I didn’t try disabling the firewall, although I did enable http and https ports. I can try it though.

As far as I know the data center does not provide a firewall. I just did the standard Firewall ID in the tutorial.

I just have a dedicated server. I would have to ask the data center if I could have access to kvm, but i’m not sure if they provide it. I would way rather just install a package that has everything. But for now I just had a cent os 7 system and first installed asterisk without knowing anything about freepbx. Possibly get the data cetner to do a reload on the os with the distro. But I think they just want to install the ones they have on their network. I would rather not have to install it again and see if there is some little thing.

I am hoping the tutorials were correct about what I had to do I just have a simple fix for why I can’t get to the gui for asterisk FreePBX.

These are the tutorials I used to install asterisk and freepbx.

I tested the firewall and it doesn’t matter. I get the test page for Apache. It says testing 1 2 3 at the top. Why am I getting this page and not the admin for free pbx. I wonder if there is an apache directive.

if you get there by adding /admin to your url, set the documentroot directory in your conf to /var/www/html/admin

I have contacted the data center and they can give me KVM access to install the distribution. It looks that might be the way to see that everything is set up right.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.