Cannot upgrade from FreePBX 10.13.66-22 to SNG7


(Jon Tice) #1

Hello,
I’m having an issue upgrading from FreePBX 10.13.66 to SNG7 following these instructions https://wiki.freepbx.org/display/PPS/Upgrading+from+FreePBX+10.13.66+to+SNG7
Specs are x86_64 with 50GB free on the HD and its a VMware VM.
All Modules are up to date via Module Admin and System Admin shows
PBX Firmware: 10.13.66-22
PBX Service Pack: 1.0.0.0
I also see, “This machine is not activated. The Free version of Sysadmin…”, but I’m performing this on a clone of our current production server to test that it works before I do it on the live server.

All checks are green when I run distro-upgrade except for Checking for outdated system with output of;
Loaded plugins: fastestmirror, kmod
Cleaning repos: base extras pbx schmooze-commercial updates upgrade
20 metadata files removed
6 sqlite files removed
0 metadata files removed
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile

preupgrade-assistant.x86_64 2.6.0-2.el6.sangoma upgrade
preupgrade-assistant-contents.noarch 0.7.5-1.el6.sangoma upgrade
redhat-upgrade-tool.noarch 1:0.7.52-1.0.1.el6.sangoma upgrade
Obsoleting Packages
preupgrade-assistant-el6toel7.noarch 0.7.1-2.el6.sangoma upgrade
preupgrade-assistant-contents.noarch 0.5.14-1.el6.centos @upg

This is the contents of /etc/yum.repos.d/upgrade.repo
[upgrade]
name = system upgrade temp repo
baseurl = http://sng7.com/upgrade6
description = Update the system
gpgcheck = 0

Where should I go from here?

EDIT: I scrolled down to the bottom of your upgrade doc https://wiki.freepbx.org/display/PPS/Upgrading+from+FreePBX+10.13.66+to+SNG7 and noticed that it mentioned the rpm -erase command, so I attempted to run “rpm --erase --nodeps preupgrade-assistant-1.0.2-36.0.1.el6.centos.x86_64” which then let yum update complete and distro-upgrade then came back all green.
EDIT 2: I ran the update but it failed with the end of the var/log/sngupdate file showing this;

… Summary information:
We have found some potential risks.
Read the full report file ‘/root/preupgrade/result.html’ for more details.
Please ensure you have backed up … from installation media is needed.
Upload results to UI by the command:
e.g. preupg -u http://example.com:8099/submit/ -r /root/preupgrade-results/preup g_results-191014173041.tar.gz .
######### Running upgrade-tool to download and prepare upgrade #########
Usage: redhat-upgrade-tool [options]
redhat-upgrade-tool: error: version must be greater than 7
######### An error occured, please check /var/log/sngupdate #########

I downloaded the tar.gz with WinSCP extracted the files with 7Zip and opened the result.html file from within the extracted folder and got the following. (0=failed/0=error/6=needs inspection)

I’m guessing the actual error is the redhat-upgrade-tool error, but I couldn’t find any help online for that issue.
If anyone has suggestions, please let me know!
Thank you


(Chasemixon) #2

I also use vmware (ESXi) and a vm for my pbx, and had trouble going to SNG7, here’s my problem/solution FreePBX 14 I’m not sure if you are having the same issues I had but maybe it will help? and vm snatshots are a wonderful thing… for failed upgrades… :slight_smile:


(Jon Tice) #4

It looks like your issue occurred after the upgrade, but my system doesn’t get past the redhat-upgrade-tool command (before the first reboot in the sequence) and the only error I’m getting is “redhat-upgrade-tool: error: version must be greater than 7”

I’m not sure if there is a log I can check for a more specific error or not, but from what I can gather, that is where I’m getting hung up.


(Chasemixon) #5

hmm, could be something with cloning process? have you just taken a snapshot of the vm and run the upgrade process on the actual VM?


(Jon Tice) #6

Not a bad suggestion, however I just attempted to upgrade the production PBX and it gave the same two errors;

redhat-upgrade-tool: error: version must be greater than 7

Error! setup_upgrade did not exit cleanly. Not enabling upgrade service

I confirmed that everything is showing as updated, activated, and licensed on this box in the GUI.
Any other thoughts?


(Jon Tice) #7

Any other suggestions?


#8

Watching…we have a bunch of virtualized 10.13.66-22 systems that we’d really like to get upgraded, but the existing paths seem problematic.


(Jon Tice) #9

I submitted a bug https://issues.freepbx.org/browse/FREEPBX-20667, but have not heard anything back yet.


(system) closed #10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.