Cannot upgrade Endpoint Manager past installed version

I cannot get EPM to update the latest version. I see some posts in this regard that I can resolve this by getting a new Deployment ID but since I am running several commercial modules, I am a reluctant to go down this path as who knows what else might break.

Current EPM
Latest EPM

All licenses are up to date. EPM has 364 days left until expiry.
Module Admin does not show any updates after

I have tried:
fwconsole ma downloadinstall endpoint --tag (and several versions after but all I get is:
No repos specified, using: [standard,commercial,extended] from last GUI settings
Unable to update module endpoint -, it does not exist:
Updating Hooks…Done
Chowning directories…Done

Also tried:
fwconsole ma downloadinstall endpoint:
No repos specified, using: [standard,commercial,extended] from last GUI settings
Starting module download from endpoint: …
The following error(s) occured:

  • Failed download module tarball from endpoint:, server may be down

Please, can anyone advise what I am doing wrong or a solution?


fwconsole ma downloadinstall endpoint --force

Hi @adell444, my apologies for not replying earlier to your fine suggestion. However, by the time I saw your response, I had already raised a ticket with Sangoma and did not want to muddy their waters by making changes.
The bizarre thing is that I made no changes and neither did Sangoma but the system “self healed”. Maybe there is more to FreePbx than we thought!
Than you again for responding.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.