Cannot register old Cisco ATA 186 to new FreePBX 16 distro

I have setupa new FreePBX 16 to replace an old trixbox server. I am trying to configure one of my old Cisco ATA 186 to work with the new installation until i purchase a newer Cisco ATA 191 or 192.

I keep getting the error
15253[2023-05-22 12:25:08] NOTICE[2692] res_pjsip/pjsip_distributor.c: Request ‘REGISTER’ from ‘“ext 106” <sip:106;user=phone>’ failed for ‘’ (callid: 1329008098 - Failed to authenticate

I have tried changing the secret to something really simple (123). I have allowed both pjsip and sip on freepbx and changed the type of the extension to sip but still not working.

This server is setup only for internal calls. The desktop softphones (Zoiper 5) work without issues.


Assuming it has SIP capabilities, try using a password with no more than 8 alphanumerical-only characters.

Don’t remember if that model has SIP firmware or not.

Set up a pjsip extension 106, leaving everything at default values except set Secret to 123

In the ATA 186, set UID0 to 106, PWD0 to 123, UID1 to 0, UseLoginID to 0

Retest. If it still fails to register, at the Asterisk command prompt type
pjsip set logger on
wait for a registration attempt, post the REGISTER request (the one with the Authorization header) and response.

Also, post a screenshot of the ATA186 settings.

It’s the only type of firmware the ATA models had.

At the top of the web interfcae it says " Cisco ATA 186 (SIP)“”

ATA186 could do H.323, MGCP or SIP, depending on firmware loaded. There was even a load that did both H.323 and SIP, featuring a ‘Use SIP’ setting. However, since it is sending REGISTER requests, it is clearly using SIP.

I tried it and it shows unknown status. When i changed t to pjsip it now shows offline.

Please confirm that you did this by deleting any conflicting chan_sip extension and creating a new pjsip extension, setting only the extension number and Secret.

Post a screenshot of the ATA settings.

Are you getting Failed to authenticate errors for both 105 and 106?

Post pjsip logger output for a failed registration attempt, including responses. If the output is lengthy, paste it at and post the last 8 characters of the URL.

I have enable the tcp on pjsip and the problem went away. Thank you all for your time!

Very strange. I thought that 186 was UDP only. Since you got Failed to authenticate errors before enabling TCP, the ATA must have been sending UDP.

I suspect that when you enabled TCP, Asterisk was restarted and that fixed an unrelated issue. As a test, try disabling TCP and see whether the ATA still registers.

You were right. i disabled the tcp and everything is ok. The only complaints i have is that sometimes the line drops as they are talking which we didn’t have with the old asterisk trixbox.

Paste the Asterisk log for a dropped call (including pjsip logger) at and post the last eight characters of the URL.

The Asterisk log is at
To include a SIP trace, at the Asterisk command prompt (not a shell prompt), type
pjsip set logger on
This is canceled by Apply Config, so turn it back on after making config changes.

You can also view Asterisk logs in the GUI at Reports → Asterisk Logfiles.

I found this for all 3 dropped calls
[2023-05-24 10:32:34] NOTICE[2682] res_pjsip_sdp_rtp.c: Disconnecting channel ‘PJSIP/105-0000002f’ for lack of audio RTP activity in 30 seconds
[2023-05-24 10:37:32] NOTICE[2682] res_pjsip_sdp_rtp.c: Disconnecting channel ‘PJSIP/111-00000032’ for lack of audio RTP activity in 30 seconds
[2023-05-24 10:47:01] NOTICE[2682] res_pjsip_sdp_rtp.c: Disconnecting channel ‘PJSIP/105-00000033’ for lack of audio RTP activity in 30 seconds

If you haven’t already done so, turn off bits 0 and 16 in Audio Mode, see Cisco ATA 186 and Cisco ATA 188 Analog Telephone Adaptor Administrator?s Guide for SIP (version 3.0) - Parameters and Defaults [Cisco ATA 180 Series Analog Telephone Adaptors] - Cisco

If that’s not your issue:

You previously posted that the 186 was extensions 105 and 106. Did you change that, or have more than one 186 in your system? What device is extension 111?

I’m not familiar with “recent” 186 firmware and had not seen the SIP Parameters screen. Is there a separate page where you enter these parameters? If so, please post a screenshot of that. If using a config file, post the contents.

We have 2 Cisco ATA. One locally (105,106) and one at a remote location (111,112) which is connected to our office constantly using Site-To-Site VPN. These are the same ATA we were using without issues on the old trixbox server. That server was using SIP and the new server is using pjsip. I don’t know if this is related. We have allowed all the UDP traffic for all ports between the remote ATA and the FreePBX server to be on the safe site until we make everything work and then we will narrow down the allowed ports. You can see the SIP Parameters of the Cisco ATA bellow. The both have the same settings. What will the suggested change on the Audio Mode does?

This is the Audio Mode settings as well.


It turns off Silence Suppression, a.k.a. Voice Activity Detection or VAD. In the old days, VAD simply meant “don’t send RTP when you’re not talking”. For various reasons, this is not a good idea on modern systems. There are now better ways to save bandwidth when there is no speech, but the 186 doesn’t support any.