Cannot register a Gigaset phone


(Alexandre Baroux) #1

I’m trying to register a Gigaset phone on Freepbx. Yesterday, I succeed to register a softphone using microSip.

On Freepbx, I created an extension, and entered the phone parameters. in the reports, the device’s status is unknown, and in the logs, I have this message:

[2020-07-16 12:11:56] NOTICE[1966] chan_sip.c: Registration from '"cohen" <sip:dect2@192.168.10.12>' failed for '192.168.10.70:5060' - Wrong password 

On the Gigaset web interface, the status is registration failed. And there is no provider selected, but when I click on select a provider, I have a notification:

> Download settings not possible! 
Transmission error 0!

Any idea about how to solve that problem?


(Communication Technologies) #2

Says wrong password. Maybe try a very simple password as a test to see if that is the issue. If it still failed, you can check ports and firewall, but the fact that FreePBX displays a result, means that it reached the server (if that is the phone).


(Alexandre Baroux) #3

I have already tried with a simple password. I have even tried with an empty password, but it didn’t work either.


(Lorne Gaetz) #4

The from header should have the extension number. You’re registering to the chan_sip port, so you should have a chan_sip extension and that extension number is the SIP username in the client.