Cannot Receive Faxes


#1

Asterisk 1.8.15
FreePBX 2.10.1.9
Grandstream GXW4104 FXO gateway, firmware version 1.3.4.10, with 3 POTS lines connected.
Admin->Module Admin shows that Fax Configuration 2.10.0.6 from Schmoozecom is installed and enabled.

The objective is to be able to receive faxes over the normal voice lines and email them to a recipient. As best I can determine this should be supported by Asterisk/FreePBX out of the box without a need for Hylafax or FFA or other. Fax Configuration 2.10.0.6 from Schmoozecom is installed and enabled.

Did the following:

In Settings->Asterisk SIP Settings, set T38 Pass-Through to Yes. However I believe this only affects receiving fax over IP and sending the fax to a fax machine. As best I can tell T.38 is not used to just receive a fax within Asterisk (right?). I just want to receive the fax and have it emailed to the recipient as a PDF or TIF or whatever.

In Applications->Extensions->my extension, checked Fax = Enabled, and put my email address in Fax Email.

In Connectivity->Inbound Routes, selected one of my incoming phone lines, set Detect Faxes = Yes, Fax Detection Type = SIP, Fax Detection Time = 4 (default), and Fax Destination to the Fax Recipient I set up above in Applications->Extensions.

In Settings->Fax Configuration, set Maximum Transfer Rate to 14400 and Minimum Transfer Rate to 4800, Error Correction Mode to Yes (but also tried No).

In the setup for the Grandstream GXW4104 FXO gateway, in FXO Lines, tried most available combinations of T.38 Setting including Relay (default) or Pass Through, all baud rates from 4800-14400, and ECM to match what I had set in FreePBX Settings->Fax Configuration above (tried both options).

Tried sending the PBX a fax from a known-good and fully functional fax machine that works everywhere else, and the PBX would not pick up on it.

I asked Grandstream and they could not help. I’ve spent most of today searching everywhere I can find for help and nothing is available that’s on-point.

Certainly someone else must be doing this?

Appreciate any help… thanks…


(Lee Mason) #2

How did you build the system? Was it from the FreePBX ISO or did you build by hand? It could be that you are missing spandsp which I was Asterisk would use by default to process faxes. I had this problem recently with a system I had to build on top of Centos 6.4 (well not quite the same but a FAX problem nonetheless).


#3

Good afternoon, Lee.

I built the system using the AsteriskNOW/FreePBX ISO for Asterisk 1.8.15/FreePBX 2.10.1.9 / CentOS 5.8. I then went in to Admin->Module Admin and enabled and installed every available module… because I planned to use this system for experimentation and to learn more about Asterisk so I figured I may as well just go ahead and install everything.

I assumed that the AsteriskNOW/FreePBX ISO would including everything needed to do the supported operations like fax reception, but I can not find anything on my system with “spandsp” in any part of any filename, in any mix of upper and lower case. So either SpanDSP is not required, in which case some other way of receiving faxes is used, or it is required, in which case no one who has downloaded and installed AsteriskNOW/FreePBX has ever gotten fax running using built-in fax capability without having to install Hylafax or similar.

If I need to install SpanDSP then I assume I also need to download the sources for Asterisk 1.8.15 and rebuild everything, right?

Eric Poole / http://www.rkt-tech.com


#4

The Asterisk Now Distribution does not have complete faxing, it leans towards using the Digium Fax for Asterisk module.

You might want to give our distro a try, it has SpanDSP.


(Lee Mason) #5

In which case switch distribution (I would recommend the latest FreePBX ISO) or yes you will need to go back to Asterisk 1.8 sources and download these as well as spandsp (which doesn’t come with the sources) and get both recompiled. You’ll have to go into “make menuselect” when you compile Asterisk and make sure that “res_fax_spandsp” is selected.


#6

Good afternoon, Scott and Lee.

I suppose if I had this to do over again I’d go with a different distro, but the PBX is days away from going live (pro bono project for a non-profit public service org) and receiving faxes was a “nice to have” but not a hard requirement. It really would be nice to have, though (they don’t care anything about being able to send faxes).

So what are my alternatives that don’t involve re-installing a different distro from scratch? Free Fax for Asterisk claims “one channel only”. What is a “channel”? We want to receive faxes over any one of the three POTS lines we have connected. Do we have to pick one line and connect that one to FFA and that’s it? Or do they just mean that only one fax can be received at a time? That would be fine.

The other alternative is Hylafax. I have done one Hylafax installation, many years ago, and it went pretty smoothly though it wasn’t tied to an Asterisk installation. Without getting into details about how to do it… I’ll RTFM and get back either here or the Hylafax forums if I have trouble… is Hylafax and the out-of-the-box AsteriskNOW / FreePBX distro a reasonable solution?


#7

One Fax at a time with the FFA license.

It would take under an hour to backup your config and restore with a new distro.

You can make your own call, but take a look at the support you get here, vs. your distro’s forums. You are going to have to live with this for awhile.


#8

SH> It would take under an hour to backup your config
SH> and restore with a new distro.

Just for fun I installed AsteriskNOW 3.0.0 on a VMware VM, did a backup of AsteriskNOW 2.0.2 and tried to restore it on 3.0.0.

“Another fine mess”, next right.

Corrupted the FreePBX screens into indecipherable gibberish.

I’ve done some reading on trying to backup one distro and restore to another and so far haven’t found anyone that’s having much luck.

SH> You can make your own call, but take a look at
SH> the support you get here, vs. your distro’s forums.

OK, now I’m a little confused… running FreePBX so isn’t this my distro’s forums?

The help available here certainly is first-rate. And that captcha thing they use here is certainly a lot easier than most, if one has to use them at all. :slight_smile:


#9

First of all you can’t backup between FreePBX version but I have published on several occasions work arounds. All that matters is the FreePBX version.

I have no idea what version of FreePBX Asterisk Now 2.0 or 3.0 use.

FreePBX and the FreePBX distro, a complete ISO distribution (like PBX in a flash, Asterisk Now etc.) are two separate projects.

Generally you should seek assistance in the forum of the distro you run.


(system) closed #10