Cannot provision DB20 DECT base station


#1

Hi,

I cannot provision an DB20 base station with the DB10 phone.
I am following the step in the wiki https://wiki.freepbx.org/display/PHON/Getting+Started+with+the+DC201#GettingStartedwiththeDC201-AddingaConfigurationServertoaDECTBasestation

But when i am changing the base station to static ip instead of DHCP after i reboot it i can see that it didnt kept my static IP.

Can you help me ?

Do i need to edit someting in the basefile in Freepbx because i think that this is the cause of my problem

Thanks


#2

Just to confirm, are you using the Endpoint Manager commercial module? I’ll assume you are for now. I’ll also assume you are not using option66 from your dhcp server to set a configuration address for the basestation, and that the db20 is local to the pbx. It should also work if remote, but you may need to involve some additional firewall/network options.

When I configured one against a FreePBX14 system, here’s what I did, starting with a db20 that had default settings. I didn’t have to edit my basefile.

On FreePBX admin:

-on Endpoint Manager->Base Station Management, I added the db20.

-The db20 needs to be an enabled model for the firmware template you choose. You may already have that set, but you’ll get a complaint if it isn’t.

-In the template, I also have the Provisioning Protocol option set to HTTP, which may be the default.

-After the basestation is added, click the icon to Edit it, and set a Handset Access Code. You’ll need this code later.

-on Endpoint Manager->Extension Mapping, I choose Add Extension, and select an extension for account 1.

-Choose Sangoma for the model, and leave the MAC Address field blank. For the Template Model, Select the correct sangoma template, and set the model to

DB20. This should now let you select the base station where the Mac Address field once was. Add the mapping.

-After the mapping is added, click the icon to Edit it. This is where you enter the DB10’s IPEI number.

-If the handset is powered up, you can find this number in the Status/Info menu. It can also be found behind the phone’s battery.

-You may see some error messages about the device not having an IPEI number when you’re trying to set one, just proceed through to get it set.

-go to Admin -> System Admin.

-go to the Port Management section. make a note of what you have for HTTP Provisioning. 84 is the default.

-go to the Provisioning Protocol section. If you have HTTP(s) authentication enabled, make a note of the username and password somewhere

This info can also be found in Endpoint Manager’s Global Settings page.

On the basestation:

-like the wiki page mentions, I made my changes in the Management Page.

-set Management Transfer Protocol to HTTP. HTTPS may work for you, but I’ve only tried HTTP.

-set the HTTP Management username and password to what you had from the Provisioning Protocol page if it was active.

-for Configuration Server Address, enter your-pbx-ip:http-provisioning-port (ex. http://192.168.1.100:84).

-set Auto Resync Polling to Enabled

-DHCP Controlled Config Server to Disabled.

-I left the other values at their defaults.

After rebooting, you’ll know if the basestation got its configuration because you can no longer access its web config with the default credentials of admin:admin. Instead, the username will still be admin, but the password will be what you have set in Endpoint Manager->Global Settings->Phone Admin Password. You can verify logging in works, but you shouldn’t have to make additional changes at this point for a basic setup.

Now on the handset’s menus, you should be able to register it(Connectivity->Register) using the Handset Access Code that was set for the basestation in Endpoint Manager. If successful, you should see the extension number show on screen, and be able to make calls.


#3

This is what i did and it worked but the problem is that it only works with DHCP enabled, if i change the DB20 to a static IP address, after i reboot the base the IP address is lost.

Also why the base does not upgrade the FW since it has connectivity with the endpoint manager ?

Thanks


#4

I know nothing about the DB20, but can you just set the desired static address in the DHCP server? That is generally more robust; if you deploy the DB20 elsewhere or move it to another LAN for testing, it will get a valid address from the new DHCP server.

IMO hard coded static IP addresses should be limited to critical infrastructure that must work even if your firewall or other DHCP server is down.


(Dave Burgess) #5

I’ll carry that one level further, and say that all of your systems (static or dynamic) should have their IP addresses “documented” in your DHCP server. Assigning reserved addresses for critical infrastructure costs nothing and supports having all of your documentation in one place, manageable by a single application or management session. If you “factory reset” a piece of gear, you want to be able to find it, especially if it’s a server, so adding this is just a belt-and-suspenders approach.


#6

DHCP:
By default, Endpoint Manager will generate a configuration where DHCP is enabled, which is probably overwriting what you set in the DB20’s web config. To use a static ip setup, you can modify the chosen template’s basefile using Endpoint Manager’s Basefile Edit tool. After selecting the correct template, these are the options you should look for and modify:
%NETWORK_WAN_SETTINGS_DHCP%:0x01
%NETWORK_WAN_SETTINGS_IP%:0.0.0.0
%NETWORK_WAN_SETTINGS_SUBNET_MASK%:255.255.255.0
%NETWORK_WAN_SETTINGS_GATEWAY%:0.0.0.0
%NETWORK_WAN_SETTINGS_DNS1%:0.0.0.0
%NETWORK_WAN_SETTINGS_DNS2%:0.0.0.0

You can click on each one to change its value. Make sure you set the value for “%NETWORK_WAN_SETTINGS_DHCP%” to 0x00. After saving and generating the configs, you may need to involve multiple reboots for this change to take effect. For example, I had my db20 set with dhcp. After rebooting it, it fetched the new config with static ip settings, but was still accessed on the dhcp address. I went to the db20’s web config by going to the original dhcp address and verified that the network settings had the new static ip values. After rebooting once more, the new network settings started getting used. I’m not sure if it would have automatically done the second reboot if I waited longer, but that’s what worked for me. Having said all that, I agree with what others have said about considering a DHCP static lease setup. But this should work.

Firmware:
The firmware that gets installed will be based on what you have set for the “Force Firmware Version” setting in the template options. If you want to force a version that’s different from the Recommended version, you can change that to something like Firmware Slot 1, and then specify what should be in slot 1 in the Firmware Management tool. Note that the version numbers listed in the Available Firmwares list is the version of a bundle of firmwares. Drag and available version number to one of the slots to see which specific firmwares are included in the bundle. I recommend leaving it at Recommended, but that’s how you can force a version from the available list. Only tested versions are included in the bundles, so you may not always see a recently released firmware immediately included in Endpoint Manager.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.