Cannot ping in the internet from FreePBX

This morning I logged in to update the modules from GUI and noticed the error: “Warning: Cannot connect to online repository(s) ( Online modules are not available.”

I have not done any changes. This configuration worked in the past when I first installed FreePBX but I haven’t logged in for 2 months.

I logged in to CLI and tried pinging and with no result.
Traceroute lists:
1 * * *
2 * * *
3 * * *
and so on.

Tried disabling the firewall, reponsive firewall and IPS, restarting the network service and the system. Doesn’t change anything.
I can still make and receive outside calls with the SIP trunk.

ETH0 is the internal network, ETH1 is the SIP network.

FreePBX IP is:
route-eth0 looks like this: via dev eth0 via dev eth0 via dev eth0 via dev eth0

ETH1 looks like this:

ETH0 looks like this:

DNS servers are:
2 internals IPs
3rd one is

route -n lists:
Destination Gateway Genmask iface eth1 eth0 eth1 eth0 eth0 eth0 eth0 eth0 eth1

What am I doing wrong? I don’t understand how it worked in the past and now it doesn’t…

It appears that your default route is via eth1 (connection to trunk), but it should be via eth0 (connection to router/firewall). Confirm that you can ping If not, it’s probably a physical connection issue, rather than configuration. If ping is ok, try commenting out the GATEWAY entry for eth1. Reboot and test.

If I comment out the Gateway for ETH1 I can ping but I can’t make calls anymore.

That suggests that the more specific routes through eth1 have the wrong destination (or you removed more than the default route).

the public SIP trunk ip is 82.76.7.xx

these are the only routes written: via dev eth0 via dev eth0 via dev eth0 via dev eth0

do I have to add another one?

If you want eth1 to be used, there has to be a route down it to whatever you want to access using it.

I want to use eth0 to access the GUI and to be able to download updates.
ETH1 to make calls through SIP.

if I delete all the entries from route-eth0 then again I can ping and access the GUI but again I can’t make calls.

If I add the Gateway to ETH1 I can’t connect to GUI anymore.

I don’t understand what am I doing wrong here as I have a similar deployment but with different IPs also set-up by me in a different location where everything works fine.

Add a route to your VoIP provider, not a default gateway

My ip is from subnet from where I will access the GUI but I also have a softphone installed and will also add a hard phone to test.

What route would send the voip data to the voip provider but send the rest to the eth0?

Sorry if I am not explaining right, I am a newbie.

What IP addresses does the provider use?

The host public IP of the SIP trunk is 82.76.7.xx
The eth1 interface of FreePBX has Gateway

is this what you were asking?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.