Cannot make Outgoing Calls

I have been working with my SIP provider but I am unable to send outgoing calls to their system. I can receive incoming call but I get the system is busy default when trying to use their sip for outgoing.

I seem to be the only user with Freepbx having this issue and they have checked and configured my outgoing setup to make sure I should be able to connect.

I am running 4.211.64-7 version, and asterisk 11.5.1. Now I believe I am the only one with the most current versions, but I can connect to my old sip provider and send and receive calls flawlessly through their system.

Hopefully someone can assist in correcting our configuration or settings.

Asterisk (Ver. 11.5.1): Sip Info

Sip Registry

Host dnsmgr Username Refresh State Reg.Time
Working SIP:5060 N 105 Registered Mon, 23 Sep 2013 13:53:54
Not working SIp:5060 N 105 Registered Mon, 23 Sep 2013 13:53:54
2 SIP registrations.

Sip Peers

Name/username Host Dyn Forcerport ACL Port Status Description
200/200 10.0.0.7 D A 5060 OK (15 ms)
250/250 10.0.0.20 D A 5060 OK (13 ms)
255/255 10.0.0.20 D A 5060 OK (14 ms)
355 (Unspecified) D A 0 UNKNOWN
Not Working 199.ip N 5060 UNREACHABLE
Working SIP 216.ip N 5060 Unmonitored
6 sip peers [Monitored: 3 online, 2 offline Unmonitored: 1 online, 0 offline]

They say I am not connecting on my outgoing to their SIP. I don’t know why one SIP configuration would work, and the other SIP where they set the parameters does not.

Let me know if you need more data.

What version of FreePBX are you using?

I am running Freepbx 2.11 latest version all modules updated, Asterisk 11.5.1, System 4.211.64-7

I only have the issue with another sip provider that I want to switch too. He can not figure out why I can’t connect. Believes it may be firewall or router settings, but its not an issue with other provider. However I can get incoming calls just can’t register or even get to him on outgoing calls.

Any help would be greatly appreciated.

All I get is all circuits are busy now message
log results
[2013-09-26 10:21:54] WARNING[27518][C-00000134] app_dial.c: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] app_dial.c: == Everyone is busy/congested at this time (1:0/0/1)
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:23] NoOp(“SIP/200-00000095”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 20”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:24] GotoIf(“SIP/200-00000095”, “0?continue,1:s-CHANUNAVAIL,1”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:1] Set(“SIP/200-00000095”, “RC=20”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:2] Goto(“SIP/200-00000095”, “20,1”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Goto (macro-dialout-trunk,20,1)
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:1] Goto(“SIP/200-00000095”, “continue,1”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Goto (macro-dialout-trunk,continue,1)
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:1] NoOp(“SIP/200-00000095”, “TRUNK Dial failed due to CHANUNAVAIL HANGUPCAUSE: 20 - failing through to other trunks”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:2] Set(“SIP/200-00000095”, “CALLERID(number)=200”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:7] Macro(“SIP/200-00000095”, “outisbusy,”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:1] Progress(“SIP/200-00000095”, “”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:2] GotoIf(“SIP/200-00000095”, “0?emergency,1”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:3] GotoIf(“SIP/200-00000095”, “0?intracompany,1”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] pbx.c: – Executing [[email protected]:4] Playback(“SIP/200-00000095”, “all-circuits-busy-now&pls-try-call-later, noanswer”) in new stack
[2013-09-26 10:21:54] VERBOSE[27518][C-00000134] file.c: – <SIP/200-00000095> Playing ‘all-circuits-busy-now.ulaw’ (language ‘en’)
[2013-09-26 10:21:55] VERBOSE[27518][C-00000134] app_macro.c: == Spawn extension (macro-outisbusy, s, 4) exited non-zero on ‘SIP/200-00000095’ in macro ‘outisbusy’
[2013-09-26 10:21:55] VERBOSE[27518][C-00000134] pbx.c: == Spawn extension (outbound-allroutes, 4851700, 7) exited non-zero on ‘SIP/200-00000095’

Log of working SIP Provider and a call

[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:12] GosubIf(“SIP/200-00000097”, “0?sub-flp-3,s,1()”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:13] Set(“SIP/200-00000097”, “OUTNUM=16164851700”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:14] Set(“SIP/200-00000097”, “custom=SIP/Flowroute”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:15] ExecIf(“SIP/200-00000097”, “0?Set(DIAL_TRUNK_OPTIONS=M(setmusic^default)Tt)”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:16] ExecIf(“SIP/200-00000097”, “0?Set(DIAL_TRUNK_OPTIONS=TtM(confirm))”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:17] Macro(“SIP/200-00000097”, “dialout-trunk-predial-hook,”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:1] MacroExit(“SIP/200-00000097”, “”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:18] GotoIf(“SIP/200-00000097”, “0?bypass,1”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:19] ExecIf(“SIP/200-00000097”, “1?Set(CONNECTEDLINE(num,i)=16164851700)”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:20] ExecIf(“SIP/200-00000097”, “1?Set(CONNECTEDLINE(name,i)=CID:6164851700)”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:21] GotoIf(“SIP/200-00000097”, “0?customtrunk”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] pbx.c: – Executing [[email protected]:22] Dial(“SIP/200-00000097”, “SIP/Flowroute/16164851700,300,Tt”) in new stack
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] netsock2.c: == Using SIP RTP TOS bits 184
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] netsock2.c: == Using SIP RTP CoS mark 5
[2013-09-26 10:27:56] VERBOSE[27605][C-00000136] app_dial.c: – Called SIP/Flowroute/16164851700
[2013-09-26 10:27:58] VERBOSE[27605][C-00000136] app_dial.c: – SIP/Flowroute-00000098 is making progress passing it to SIP/200-00000097
[2013-09-26 10:28:04] VERBOSE[27605][C-00000136] app_dial.c: – SIP/Flowroute-00000098 is ringing
[2013-09-26 10:28:04] VERBOSE[27605][C-00000136] app_dial.c: – SIP/Flowroute-00000098 is making progress passing it to SIP/200-00000097
[2013-09-26 10:28:09] VERBOSE[27605][C-00000136] app_macro.c: == Spawn extension (macro-dialout-trunk, s, 22) exited non-zero on ‘SIP/200-00000097’ in macro ‘dialout-trunk’
[2013-09-26 10:28:09] VERBOSE[27605][C-00000136] pbx.c: == Spawn extension (outbound-allroutes, 4851700, 6) exited non-zero on ‘SIP/200-00000097’

bump

Are there any ideas?

Perhaps you can post the configs of the 2 trunks to compare.

And a SIP debug. The log clearly shows the trunk thinks the channel is not available.

Where do I get the SIP debug report? How do I print configurations, need to be careful don’t want username and access issues. I can connect to Flowroute.com but not to e4sip

Thanks

From the console:

core set verbose 0 (this turns off dialplan debug)
sip set debug on

Then try and make the call. Cut and past between your SSH window and your browser to the forum, or if it is long use pastebin.ca

make sure you turn off

sip set debug off

There is no sensitive info in sip settings page. You can also redact the first octet of your outside IP.

Thank you will do. What does you can then redact the first octlet of your outside ip mean? Also does the debug turn on in log files reports or does it print on the ssh window? Thanks

Redacting the first octet of the IP means to change the first part of the IP address to just XXX if you want, for security concerns. enabling debug of various types will store to log as well as print to the screen, so remember to turn the levels down (or off) later to avoid filling up your drive with junk.

Thanks when I try core set verbose 0, I get command not found? This is from root.
Any suggestions?

Dont do it from root, but from asterisk CLI.

BF

ok did that but how much of the full log do I print and send? 100 lines? I don’t see a sip log
Should I also then manually remove any IP strings etc?

Did you do the sip set debug on ?

You should see many SIP transactions.

Try to limit it to the invite of the failed call. Each message will be 5 or 6 lines. It will follow a logical flow.

Also once you grab it out of full you can use find/replace in a text editor to remove your external IP.

Please post at pastebin.ca and just put a link in your forum post. It keeps the thread clean and is much easier to read.

Here is the link to the log file
http://pastebin.ca/2460955
Please let me know your comments.

Did the report come thru? Any ideas how to fix

You have a NAT/translation problem with your router:

I can tell because of the unreachable peer messages