Cannot get port 5060 open

I have a brand new install of FreePBX Distro 5.211.65-14. I am unable to get port 5060 open nor am I able to connect a phone.

My intent is to connect via SIP through NAT, but I cannot even get any indication that the machine is listening on 5060. Here is what I have done thus far.

  1. “module show like sip” shows which tells me SIP is loaded

  2. I have configured two extensions on 5060 so I should be listening

  3. I have tried turning off the firewall with service iptables stop just to verify its not a firewall issue

  4. I have verified the SIP is configured with NAT and my internal and external IP addresses which are correct

  5. I have tried amportal stop / amportal start and also restarted the entire machine

Any help would be appreciated. One would think that opening up 5060 on a PBX would not take days of troubleshooting… Sigh.

Module show… Shows what’s available, this doesn’t mean loaded

Port 5060 is a global setting not a per extension setting.

What does the following show

nmap -v -sV localhost -p 5060 

are the phones and the server on the same network?

nmap -v -sV localhost -p 5060 shows:

tcp/5060 closed sip

This is my underlying problem. I do not seem to be able to find the listener that should be listening on this port. I am sure that I am missing some simple setting, but I cannot seem to find any one place that has a document which describes all the steps needed to get port 5060 listening.

I appreciate your help!

Alan, Thanks for you help. Phones and server are not on the same network. The server is on a datacenter and my intent is to connect via SIP through a firewall. Ports for SIP and RTP are open and forwarded. However, the server is not even listening on 5060, so clearly I am never going to be able to connect on 5060 no matter local or remote.

By default SIP is UDP not TCP, chan_sip is the listener and it is on by default.

Something else is going on.

You can check the network stack with tcpdump and see that the packets are arriving on the interface.

Asterisk also has it’s own SIP decoder sip set debug (with either and IP or peer designator)

I am having the same problem. Does anybody have a solution? I think that on my instance of FreePBX, port 5060 is closed externally but I do not know how to open it. All firewalls are off and I ran Nmap but I get that port 5060 is closed too.

Very unlikely. Please start a new thread and provide complete information, including logs (on and screen shots of your actual configuration.

For a start, they were using chan_sip, but you should be using chan_pjsip.