Cannot get paging/intercom to work

Hi All,

I set up two sip phone extensions to a paging/intercom group 222.
When I dial 222, it rolls to a voicemail, if I disable that voicemail, when I dial 222 I get a fastbusy.

When I dial *80, the extension does answer and I can intercom to that just fine. Running the new version of freepbx… What am I doing wrong?

here’s debug:
– Executing [[email protected]:1] Goto(“SIP/tociscortr-00000023”, “ext-local,vmu1212,1”) in new stack
– Goto (ext-local,vmu1212,1)
– Executing [[email protected]:1] Macro(“SIP/tociscortr-00000023”, “vm,1212,NOANSWER,”) in new stack
– Executing [[email protected]:1] Macro(“SIP/tociscortr-00000023”, “user-callerid,SKIPTTL”) in new stack
– Executing [[email protected]:1] Set(“SIP/tociscortr-00000023”, “AMPUSER=6969”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/tociscortr-00000023”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/tociscortr-00000023”, “1?Set(REALCALLERIDNUM=6969)”) in new stack
– Executing [[email protected]:4] Set(“SIP/tociscortr-00000023”, “AMPUSER=”) in new stack
– Executing [[email protected]:5] Set(“SIP/tociscortr-00000023”, “AMPUSERCIDNAME=”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/tociscortr-00000023”, “1?report”) in new stack
– Goto (macro-user-callerid,s,13)
– Executing [[email protected]:13] GotoIf(“SIP/tociscortr-00000023”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,26)
– Executing [[email protected]:26] Set(“SIP/tociscortr-00000023”, “CALLERID(number)=6969”) in new stack
– Executing [[email protected]:27] Set(“SIP/tociscortr-00000023”, “CALLERID(name)=Shelley’s”) in new stack
– Executing [[email protected]:28] Set(“SIP/tociscortr-00000023”, “CHANNEL(language)=en”) in new stack
– Executing [[email protected]:2] Set(“SIP/tociscortr-00000023”, “VMGAIN=”"") in new stack
– Executing [[email protected]:3] Macro(“SIP/tociscortr-00000023”, “blkvm-check,”) in new stack
– Executing [[email protected]:1] Set(“SIP/tociscortr-00000023”, “GOSUB_RETVAL=”) in new stack
– Executing [[email protected]:2] ExecIf(“SIP/tociscortr-00000023”, “0?Set(GOSUB_RETVAL=TRUE)”) in new stack
– Executing [[email protected]:3] MacroExit(“SIP/tociscortr-00000023”, “”) in new stack
– Executing [[email protected]:4] GotoIf(“SIP/tociscortr-00000023”, “1?vmx,1”) in new stack
– Goto (macro-vm,vmx,1)
– Executing [[email protected]:1] Set(“SIP/tociscortr-00000023”, “MEXTEN=1212”) in new stack
– Executing [[email protected]:2] Set(“SIP/tociscortr-00000023”, “MMODE=NOANSWER”) in new stack
– Executing [[email protected]:3] Set(“SIP/tociscortr-00000023”, “RETVM=”) in new stack
– Executing [[email protected]:4] Set(“SIP/tociscortr-00000023”, “MODE=unavail”) in new stack
– Executing [[email protected]:5] GotoIf(“SIP/tociscortr-00000023”, “1?chknomsg”) in new stack
– Goto (macro-vm,vmx,8)
– Executing [[email protected]:8] GotoIf(“SIP/tociscortr-00000023”, “0?s-NOANSWER,1”) in new stack
– Executing [[email protected]:9] GotoIf(“SIP/tociscortr-00000023”, “1?notdirect”) in new stack
– Goto (macro-vm,vmx,11)
– Executing [[email protected]:11] NoOp(“SIP/tociscortr-00000023”, “Checking if ext 1212 is enabled: “) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/tociscortr-00000023”, “1?s-NOANSWER,1”) in new stack
– Goto (macro-vm,s-NOANSWER,1)
– Executing [[email protected]:1] Macro(“SIP/tociscortr-00000023”, “get-vmcontext,1212”) in new stack
– Executing [[email protected]:1] Set(“SIP/tociscortr-00000023”, “VMCONTEXT=default”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/tociscortr-00000023”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing [[email protected]:300] NoOp(“SIP/tociscortr-00000023”, “”) in new stack
– Executing [[email protected]:2] VoiceMail(“SIP/tociscortr-00000023”, “[email protected],u”””) in new stack
– <SIP/tociscortr-00000023> Playing ‘vm-theperson.ulaw’ (language ‘en’)
– <SIP/tociscortr-00000023> Playing ‘digits/1.ulaw’ (language ‘en’)
– <SIP/tociscortr-00000023> Playing ‘digits/2.ulaw’ (language ‘en’)
– <SIP/tociscortr-00000023> Playing ‘digits/1.ulaw’ (language ‘en’)
– <SIP/tociscortr-00000023> Playing ‘digits/2.ulaw’ (language ‘en’)
== Spawn extension (macro-vm, s-NOANSWER, 2) exited non-zero on ‘SIP/tociscortr-00000023’ in macro ‘vm’
== Spawn extension (ext-local, vmu1212, 1) exited non-zero on ‘SIP/tociscortr-00000023’
– Executing [[email protected]:1] Macro(“SIP/tociscortr-00000023”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/tociscortr-00000023”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] Hangup(“SIP/tociscortr-00000023”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘SIP/tociscortr-00000023’ in macro ‘hangupcall’
== Spawn extension (ext-local, h, 1) exited non-zero on ‘SIP/tociscortr-00000023’

Still have the problem any help is appreciated :slight_smile:

seems like paging/intercom is buggy still in 2.10.
I had to add my pagegroup 222 to a ringgroup. When i dial that ringgroup, it works.