Cannot Connect to Online Repository (mirror1.freepbx.org, mirror2.freepbx.org)

Cannot Connect to Online Repository (mirror1.freepbx.org, mirror2.freepbx.org) to my Freepbx 15.0.16.37 system. Is this a known issue?

Not sure if it is known to the FreePBX team, but I am having the same issue. Bad timing, as I was planning to attempt the upgrade to v15 today.

It is helpful to know that it isn’t just me…

I’m seeing the same thing. Also bad timing as I had to roll back to a snapshot from four days ago (managed to lock myself out of the system) and I know that a bunch of modules had been updated in that time span.

Edit - forgot that I’d had this problem once before but that time the mirrors came back up before I saw the reply or had a chance to try the proposed solution. Well I tried it today, and it works!

So it looks like mirror2.freepbx.org is the offending repository, as pings do work to mirror1. I tried all the various old tricks to clear the issue and confirmed it isn’t blocked by my firewall.
I further confirmed that iptables on the freepbx instance correctly has the IPv4 /32 for both mirror1 and mirror2 in the fpbxhosts chain as -j zone-trusted

Hopefully someone at Sangoma will look into:

  1. What’s up with the mirrors
  2. Do things work fine just using mirror1 while mirror2 is offline?

I’m also having this issue. No recent updates and was planning an update to v15 today. I’m running v14.0.13.12.

I’ve also tried all the usual steps. I ran fwconsole ma updateall and that ran without issue. I also ran a wget to mirror 1 and that timed out - but the ip was resolved.

Good to know it’s not just my system having issues.

Both seem to be having issues. Yes, mirror1 responds to ping, but I am unable to download the upgrade module from it.

I am in the same boat.
I am on official PBX distro 14.0.13.12
System version 12.7.6-1910-1.sng7

See my edited third post above or just go directly to Attempting to connect to mirror.freepbx.org returns "ERROR 503: Service Unavailable." and read the second post.

1 Like

Basically, run this:

fwconsole setting MODULE_REPO https://mirror.freepbx.org

And everything will be better 8)

2 Likes

Not if you are trying to install.

The new mirror rob posted (Which is https) is the default for new installs.

1 Like

This is not going well for me at all with the mirrors:

$ fwconsole setting MODULE_REPO https://mirror.freepbx.org

$ fwconsole ma install pm2
Installing/Updating Required Libraries. This may take a while…The following messages are ONLY FOR DEBUGGING. Ignore anything that says ‘WARN’ or is just a warning
npm WARN deprecated [email protected]: Package no longer supported. Contact [email protected] for more info.
Installed npm-cache v0.7.0
Running installation…
[npm-cache] [INFO] using /home/asterisk/.package_cache as cache directory
[npm-cache] [INFO] [composer] Dependency config file /var/www/html/admin/modules/pm2/node/composer.json does not exist. Skipping install
[npm-cache] [INFO] [npm] using package-lock.json instead of package.json
[npm-cache] [INFO] [npm] config file exists
[npm-cache] [INFO] [npm] cli exists
[npm-cache] [INFO] [npm] hash of /var/www/html/admin/modules/pm2/node/package-lock.json: 8f54767c7dcc88e7626d45dee6f459c8
[npm-cache] [INFO] [npm] running [npm install]…

HERE IT JUST HANGS

Go into advanced settings and turn off the proxy repo for node. I don’t remember the exact setting name. Search for proxy.

That’s all well and good, but you can’t download the FreePBX installation tarballs: Both:

http://mirror.freepbx.org/modules/packages/freepbx/freepbx-14.0-latest.tgz

and

http://mirror.freepbx.org/modules/packages/freepbx/freepbx-15.0-latest.tgz

fail with:

503 Service Unavailable

No server is available to handle this request.

Well, my issue started only after the mirrors went down, and it’s not the proxy setting.
It’s 4AM here now so I need to give up and try again in the morning!

is there a way to do this through the web UI? Got one system I don’t currently have SSH access to.

I am trying to update FreePBX from 12 to 13 and this is causing me problems. I am at the last step running this script and it cant find the mirror1 and 2. How can i update it in the CLI so i cant complete the upgrade?
https://upgrades.freepbxdistro.org/stable/10.13.66/upgrade-10.13.66-1.sh

But there are other dependencies on mirror.freepbx.org.

As stated above npm is still an issue.

Also - the sipsettings install (part of the core install - n) makes a call to “fwconsole extip” and bombs out the entire install after the timeout. fwconsole extip is trying to access http://mirror.freepbx.org/whatsmyip.php. The https version of the URL works.

Grepping around and changing the source as appropriate for both issues gets things going, but ideally shouldn’t be necessary. sipsettings could continue without the extip, the npm stuff could fall back to no proxy. Both maybe with a warning.

Probably should file a report, but family is about to show up for Christmas gatherings for now.

Ah right. That’s a very good point.

This seems to be a recurring and embarrassing problem for FreePBX IT Dept.