Cannot connect to online repository after 2.10 upgrade

I began the upgrade in Module Admin by first downloading the upgrade tool and then executing it. Initially the GUI was completely broken. Although it was coming up it asked me for a password repeatedly and most screens were completely unformatted with no menu structure. I tried updating manually from some instructions that had me download a beta/rc. Still not working. After updating my PHP to 5.3 and fixing a permissions issue in a “sessions” folder my GUI is now working and voice system is also working correctly. I am now left with only the Admin modules and Core in 2.10 (some beta) and I am unable to connect to the online repository to complete the module upgrade.

Error is: Warning: Cannot connect to online repository (, Online modules are not available.

Log file entries:
2012-Jan-30 18:44:15 /var/www/html/admin/libraries/utility.functions.php:402
[WARNING]: file_get_contents() [function.file-get-contents]: php_network_getaddresses: getaddrinfo failed: Name or service not known

2012-Jan-30 18:44:15 /var/www/html/admin/libraries/utility.functions.php:402
[WARNING]: file_get_contents(, [function.file-get-contents]: failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known

I am able to “wget” with no problem.

Any help or guidance is greatly appreciated.

Should I maybe post in a different area? Thanks for any help.

Just wondering – have you come up with any progress?

I had to re-install FreePBX after a failed 2.10 upgrade.
I now have everything working 99% okay, but have the exact error you do.

Not sure if there are (where there are) any config files that we can adjust?


I had a similar problem -
running freepbx under suphp on apache

I altered the suphp.conf file as per

Try change

;PATH environment variable


;PATH environment variable

This worked for me!

Note: my problem was when it used wget to retrieve the xml/modules