Cannot check Voice mail, wrong password

I have been posting on a thread titled VoiceMail and Contexts. I have gotten no resolution. Here is a overview.

I am using Asterisk 1.2.7.1 with FreePBX version 2.1.0. *97 connects to the mail box and then asks for the password. When I put in the password it pauses for a short time and then tells me the password is incorrect. I have checked and double checked the contexts. I have changed the contexts. I disabled the password requirement for the voice mail. I was able to get into the mailbox but no keypad entry was accepted. Nothing Works. Any help in this matter would be appreciated.

Here is the CLI trace for a call to check VM

[code:1] – Remote UNIX connection
– Executing Answer(“SIP/227-e774”, “”) in new stack
– Executing Wait(“SIP/227-e774”, “1”) in new stack
– Executing Macro(“SIP/227-e774”, “user-callerid|”) in new stack
– Executing GotoIf(“SIP/227-e774”, “0?report”) in new stack
– Executing GotoIf(“SIP/227-e774”, “0?start”) in new stack
– Executing Set(“SIP/227-e774”, “REALCALLERIDNUM=227”) in new stack
– Executing NoOp(“SIP/227-e774”, “REALCALLERIDNUM is 227”) in new stack
– Executing Set(“SIP/227-e774”, “AMPUSER=227”) in new stack
– Executing Set(“SIP/227-e774”, “AMPUSERCIDNAME=Darla Woody”) in new stack
– Executing GotoIf(“SIP/227-e774”, “0?report”) in new stack
– Executing Set(“SIP/227-e774”, “CALLERID(all)=Darla Woody <227>”) in new stack
– Executing NoOp(“SIP/227-e774”, “Using CallerID “Darla Woody” <227>”) in new stack
– Executing Macro(“SIP/227-e774”, “get-vmcontext|227”) in new stack
– Executing Set(“SIP/227-e774”, “VMCONTEXT=default”) in new stack
– Executing GotoIf(“SIP/227-e774”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing NoOp(“SIP/227-e774”, “”) in new stack
– Executing VoiceMailMain(“SIP/227-e774”, “[email protected]”) in new stack
– Playing ‘vm-password’ (language ‘en’)
– Incorrect password ‘’ for user ‘227’ (context = default)
– Playing ‘vm-incorrect’ (language ‘en’)
– Playing ‘vm-password’ (language ‘en’)
– Incorrect password ‘’ for user ‘227’ (context = default)
– Playing ‘vm-incorrect’ (language ‘en’)
– Playing ‘vm-password’ (language ‘en’)
– Executing Macro(“SIP/227-e774”, “hangupcall”) in new stack
– Executing ResetCDR(“SIP/227-e774”, “w”) in new stack
– Executing NoCDR(“SIP/227-e774”, “”) in new stack
– Executing Wait(“SIP/227-e774”, “5”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘SIP/227-e774’ in macro ‘hangupcall’
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on 'SIP/227-e774’
CHOL_ASTERISK*CLI>
[/code:1]

Its not detecting any DTMF tones from your phone. Ensure that you have configured the correct dtmfmode for the phone you’re using.

It seems to me that if it were not detecting DTMF than nothing would work. Why is it only the voice mail that does not work.

ALso It worked before I upgraded to the new * and FreePBX.

I have 3 options on the GrandStream phones i am using.
in audio, Via RTP, Via SIP info

it is currently set to in Audio on all phones.

Again.

What phone?
Did you set the phone to use RFC2833 for DTMF?

Details, Details please/

On 6/6/06, jvhowell [email protected] wrote:

[quote] Here is the CLI trace for a call to check VM

   – Remote UNIX connection
    – Executing Answer(“SIP/227-e774”, “”) in new stack
    – Executing Wait(“SIP/227-e774”, “1”) in new stack
    – Executing Macro(“SIP/227-e774”, “user-callerid|”) in new stack
    – Executing GotoIf(“SIP/227-e774”, “0?report”) in new stack
    – Executing GotoIf(“SIP/227-e774”, “0?start”) in new stack
    – Executing Set(“SIP/227-e774”, “REALCALLERIDNUM=227”) in new stack
    – Executing NoOp(“SIP/227-e774”, “REALCALLERIDNUM is 227”) in new stack
    – Executing Set(“SIP/227-e774”, “AMPUSER=227”) in new stack
    – Executing Set(“SIP/227-e774”, “AMPUSERCIDNAME=Darla Woody”) in new stack
    – Executing GotoIf(“SIP/227-e774”, “0?report”) in new stack
    – Executing Set(“SIP/227-e774”, “CALLERID(all)=Darla Woody <227>”) in new stack
    – Executing NoOp(“SIP/227-e774”, “Using CallerID “Darla Woody” <227>”) in new stack
    – Executing Macro(“SIP/227-e774”, “get-vmcontext|227”) in new stack
    – Executing Set(“SIP/227-e774”, “VMCONTEXT=default”) in new stack
    – Executing GotoIf(“SIP/227-e774”, “0?200:300”) in new stack
    – Goto (macro-get-vmcontext,s,300)
    – Executing NoOp(“SIP/227-e774”, “”) in new stack
    – Executing VoiceMailMain(“SIP/227-e774”, “[email protected]”) in new stack
    – Playing ‘vm-password’ (language ‘en’)
    – Incorrect password ‘’ for user ‘227’ (context = default)
    – Playing ‘vm-incorrect’ (language ‘en’)
    – Playing ‘vm-password’ (language ‘en’)
    – Incorrect password ‘’ for user ‘227’ (context = default)
    – Playing ‘vm-incorrect’ (language ‘en’)
    – Playing ‘vm-password’ (language ‘en’)
    – Executing Macro(“SIP/227-e774”, “hangupcall”) in new stack
    – Executing ResetCDR(“SIP/227-e774”, “w”) in new stack
    – Executing NoCDR(“SIP/227-e774”, “”) in new stack
    – Executing Wait(“SIP/227-e774”, “5”) in new stack
  == Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘SIP/227-e774’ in macro ‘hangupcall’
  == Spawn extension (macro-hangupcall, s, 3) exited non-zero on 'SIP/227-e774’
CHOL_ASTERISK*CLI>


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

[/quote]


Tom Vile
Baldwin Technology Solutions, Inc
Consulting - Web Design - VoIP Telephony
www.baldwintechsolutions.com
Phone: 518-631-2855 x205
Fax: 518-631-2856


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

Post generated using Mail2Forum (http://www.mail2forum.com)

What phone?
Did you set the phone to use RFC2833 for DTMF?

Details, Details please/

On 6/6/06, jvhowell [email protected] wrote:

[quote] I have been posting on a thread titled VoiceMail and Contexts. I have gotten no resolution. Here is a overview.

I am using Asterisk 1.2.7.1 with FreePBX version 2.1.0. *97 connects to the mail box and then asks for the password. When I put in the password it pauses for a short time and then tells me the password is incorrect. I have checked and double checked the contexts. I have changed the contexts. I disabled the password requirement for the voice mail. I was able to get into the mailbox but no keypad entry was accepted. Nothing Works. Any help in this matter would be appreciated.


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

[/quote]


Tom Vile
Baldwin Technology Solutions, Inc
Consulting - Web Design - VoIP Telephony
www.baldwintechsolutions.com
Phone: 518-631-2855 x205
Fax: 518-631-2856


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

Post generated using Mail2Forum (http://www.mail2forum.com)

I am using the GrandStream GXP2000 DTMF is in-audio

just a post to bump it to the top of the list

read this and see if it will help you
http://www.voip-info.org/wiki/view/Asterisk+SIP+DTMF

From: “jvhowell” [email protected]
Reply-To: [email protected]
To: [email protected]
Subject: Re: [Amportal-users] Cannot check Voice mail, wrong password
Date: Wed, 14 Jun 2006 10:57:04 -0600

just a post to bump it to the top of the list


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

Post generated using Mail2Forum (http://www.mail2forum.com)

Send DTMF: X (in-audio) X (via RTP (RFC2833)) X (via SIP INFO)
You need to check all of these 3 setting to work on GrandStrean phones,
Once you do this save the settings then reboot the phone.