Cannot call extensions from analog extensions

Running 3.211.63-5 w/ dahdi 2.11.18

Have a Sangoma FXO/FXS card and cannot call internal extensions from the analog ports.

The analog extension that cannot originate a call can receive calls, but can make outbound trunk calls and can call a ring group

extensions starting with 2 appear to be invalid extensions
extensions starting with 3 dont even break dialtone
Can dial a conference on ext 501
Can dial a ring group on ext 601
Can dial feature codes

-- Executing [[email protected]:3] GotoIf("DAHDI/3-1", "1?outbound-2-3-4-7-8-15-16,01,2:outbound-allroutes,01,2") in new stack
-- Goto (outbound-2-3-4-7-8-15-16,01,2)

[2013-03-01 15:18:23] WARNING[28157][C-000002ea]: pbx.c:6390 __ast_pbx_run: Channel ‘DAHDI/3-1’ sent to invalid extension but no invalid handler: context,exten,priority=outbound-2-3-4-7-8-15-16,01,2

It appears that the analog sets are trying to grab an outbound trunk, however all of the IP sets are able to call the 200 range extension numbers.

If dialing extension 201, it appears that the 2 is being stripped off, but why is it not doing it with all extensions instead of just the analog?

Any suggestions?

Hi

How do you create the analog extensions? Custom Extensions with a DAHDI dial string?

I created the extension under “Extensions” and chose Dahdi as the type.

Actually just fixed it - when I created the extension the context was set to from-internal, changed it to from-analog and that makes it work.

Thanks for the reply

I thought changing the analog/dahdi extension to from-analog it corrected the problem.

What it did do was allow it to dial, but the sip extensions are treating it as an inbound trunk call and it’s ringing my any number ring group.

If I set it back to from-internal as it is when the extension is created to drops the call with a fast busy, and again it appears that its trying to treat the call as a trunk call.

Not sure if its something I did, an issue with the Sangoma card, or freepbx?

The DAHDI extensions need to be in from-internal

from-analog is analogous to from-trunk without the DNIS decoding for DID.

Thanks for the reply SkykingOH.

If I use from-internal it drops the calls and the CLI looks like it is stripping the first digit and trying to make an external call, if it has a 0 or 1 in the string - if it doesn’t have a 0 or 1 it doesn’t do anything other than return dial tone.

If I use from-analog it will at least dial a number, although the system sees it as an external call.

DAHDI> GLOBAL SETTINGS> Other Global Dahdi Settings:
relaxdtmf=yes

Reload & Restart

Seems to have solved the problem

So it was falsing DTMF is why you thought it was dropping digits?

I assume you now have in from-internal context?

Yes, context is from-inernal

Looking at the string from above, I dialed 201, but it only showed 01

It also would dial an extension starting with a 3, however it would dial an extension starting with any other digit or a feature code starting with *, and would dial a trunk call, as long as the first digit wasnt a 2 or 3

Tried the card in another system and same result

It also would dial an extension starting with a 3,

Should read…

It also NOT dial an extension starting with a 3,