Can´t log in over SSH or SFTP (WinSCP) "Wrong password"?


(Alex Dietz82) #1

Hello,

I am trying to access my FreePBX via WinSCP. Unfortunately, the connection is always rejected. Allegedly wrong password. However, the password is correct via the GUI. The connection is also rejected via SSH. I have set up a new FreePBX for testing, but the problem is exactly the same.
I am in a local network, no VPN. It used to work months ago, since then nothing has been changed in the network.
I don’t remember there being any trick to make the connection work.
Can anyone help me?


(Richard Smith) #2

The Root password on SSH is usually different from the GUI. It sounds like you are using an incorrect password. If they are fresh installs then the root password defaults to sangoma I think but worth checking the wiki.


(Alex Dietz82) #3

Unfortunately, I can’t find anything helpful. Rather, even more confusing. A GUI called SBC.


(Richard Smith) #4

Is it an appliance or self install? If it’s an appliance the default is sangoma but otherwise I think it prompts you to create one. If it’s a hosted system on Vultr etc they normally create a strong root password for you and is stored in their platform.


(Alex Dietz82) #5

I have created the system myself with the ISO of the FreePBX homepage. I entered the root password during the installation. Normally, SSH and sFTP should be activated and the root login + assigned password should work.
The funny thing is, the old system on a Raspberry also says the wrong password, although it definitely worked a few weeks ago.


(Richard Smith) #6

Have you tried SSH from a different PC, just to rule out a PC input issue?


(Sholinaty) #7

can you log in with that user from a hard-wired keyboard/monitor?
is ssh just disabled for the root user?


(Jared Busch) #8

You can always interrupt the grub boot menu and get in.