Can not sometimes make a Incoming or Outgoing calls

Hello i have a small problem My pbx was working without no problem for a year now I’m having a problem. I have a older Freepbx version not sure what it is. But i also have a grandstream fxo gateway 4 port GXW4104. Somehow incoming sometimes work or doesn’t work it keeps going to voicemail on the Ext line. But out going sometimes work and sometimes says all circuits are busy. I do not know what to do. Can someone please help me. I have took a phone that can connect directly to the ptsn analog phone line and test it. And it works with no problem incoming or out going.

Joseph

Hello i decided to make a new freepbx server using the same version as i did before. Everything is setup, Incoming calls works. However outbound calls i get a Error message saying all ciruits are busy.

Here is what I’m getting from the asterisk area.

[2020-03-28 13:46:57] WARNING[23253][C-00000021]: app_dial.c:2437 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [[email protected]:23] NoOp(“SIP/801-0000002c”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 20”) in new stack
– Executing [[email protected]:24] GotoIf(“SIP/801-0000002c”, “0?continue,1:s-CHANUNAVAIL,1”) in new stack
– Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
– Executing [[email protected]:1] Set(“SIP/801-0000002c”, “RC=20”) in new stack
– Executing [[email protected]:2] Goto(“SIP/801-0000002c”, “20,1”) in new stack
– Goto (macro-dialout-trunk,20,1)
– Executing [[email protected]:1] Goto(“SIP/801-0000002c”, “continue,1”) in new stack
– Goto (macro-dialout-trunk,continue,1)
– Executing [[email protected]:1] NoOp(“SIP/801-0000002c”, “TRUNK Dial failed due to CHANUNAVAIL HANGUPCAUSE: 20 - failing through to other trunks”) in new stack
– Executing [[email protected]:2] Set(“SIP/801-0000002c”, “CALLERID(number)=801”) in new stack
– Executing [[email protected]:8] Macro(“SIP/801-0000002c”, “outisbusy,”) in new stack
– Executing [[email protected]:1] Progress(“SIP/801-0000002c”, “”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/801-0000002c”, “0?emergency,1”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/801-0000002c”, “0?intracompany,1”) in new stack
– Executing [[email protected]:4] Playback(“SIP/801-0000002c”, “all-circuits-busy-now&pls-try-call-later, noanswer”) in new stack
– <SIP/801-0000002c> Playing ‘all-circuits-busy-now.ulaw’ (language ‘en’)
> 0x7f4d8c05c170 – Probation passed - setting RTP source address to 10.1.10.252:19208
– <SIP/801-0000002c> Playing ‘pls-try-call-later.ulaw’ (language ‘en’)
== Spawn extension (macro-outisbusy, s, 4) exited non-zero on ‘SIP/801-0000002c’ in macro ‘outisbusy’
== Spawn extension (from-internal, XXXXXXXXXX, 8) exited non-zero on ‘SIP/801-0000002c’
– Executing [[email protected]:1] Hangup(“SIP/801-0000002c”, “”) in new stack
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/801-0000002c’

I tried everything. And i can not get it to work. Here is my dialout plan

dialingplan

Can someone please help me?

Joseph

check the networks settings under sip settings

Asterisk sip settings has a external and a interal address. I’m using a older version of freepbx not a newer one.

I’m assuming you’ve set up your outbound routes?

Hello the problem was the asterisk Sip settings internal and external addressing i set it incorrectly. And it is fix now Thank you so much.

Joseph

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.