Can not make Video call using PJSIP


i just installed Asterisknow, all extension working fine but i notice i can not do video call.

please how can i activate this? i have tried adding h246 under each user extension---- allow codex but immediately i do that i will not be able to call out again from that very extension.

please help

Show us your configuration and the cli output when you make a call to see what’s happening.

fail to establish call

under allowed codes under extensions you would need to add the following…


The annoying part I am still struggling with is that when you dial out on SIP trunks with this config your phone still shows you on the camera and a blank image where the remote party would be. On the T58V from yealink you then go full screen and lose menu options.

I haven’t looked any farther into that yet. But the setting I posted above will allow you to make local video calls and dial out.

Have you tried with one extension set to CHAN_SIP instead of CHAN_PJSIP ?

Many issues have been reported when using PJSIP, and a move to SIP fixes it immediately, maybe your issue is one of those.

i have added h264,ulaw,alaw but now what am getting is waiting for remote video … at all

Its not an issue with PJSIP, there is just no GUI setting for PJSIP and video codecs (as there are with chansip)

Also when you add Allowed Codecs entry to a PJSIP extension it must include all codecs that will be used, not just the one you want to add. It doesn’t read that way in the GUI.

Just enter under each extension, under Advanced - Allowed Codecs, the following


Or any other codecs you are using (OPUS, etc). h264 covers video, ulaw covers US calling, alaw covers international VOIP for the most part.

video call not showing, all i see is waiting for remote video


What model phones do you have?
Is your FreePBX hosted or local?