Can not Install freePBX 14 on CentOS 7 getting Fatal Error Call to undefined method FreePBX\Database::migrateXML()

I have tried to solve this my many ways, i have prepared a clean installation of CentOS minimal and i have followed the steps of this guide:

https://wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+CentOS+7

but i get the exactly the same result, i can’t install this.

migrateXML() CentOS 7

seems like there is one missing method, but i could not find the source code of that class or method

i have followed every step without getting error, nothing less… nothing more… everystep… everything works, mysql empty password… every recommendation followed… so what is wrong???

This is fixed in the latest tarball which you will have to download.

i just have downloaded again and now im getting something different, here is the screenshot…

utility_functions_line207

i already tried…

./install -f

and i get the same thing :frowning:

I have the same error !!

[[email protected] freepbx]# ./install -n
Assuming you are Database Root
Checking if SELinux is enabled…Its not (good)!
Reading /etc/asterisk/asterisk.conf…Done
Checking if Asterisk is running and we can talk to it as the ‘asterisk’ user…Yes. Determined Asterisk version to be: 14.7.5
Preliminary checks done. Starting FreePBX Installation
Checking if this is a new install…Yes (No /etc/freepbx.conf file detected)
Database Root installation checking credentials and permissions…Connected!
Empty asterisk Database going to populate it
Updating tables admin, ampusers, cronmanager, featurecodes, freepbx_log, freepbx_settings, globals, module_xml, modules, notifications…
In utility.functions.php line 207:

**SELECT value FROM admin WHERE variable = ‘version’
**

** SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘asterisk.admin’ doesn’t exist::**

install [–dbengine DBENGINE] [–dbname DBNAME] [–cdrdbname CDRDBNAME] [–dbuser DBUSER] [–dbpass DBPASS] [–user USER] [–group GROUP] [–dev-links] [–skip-install] [–webroot WEBROOT] [–astetcdir ASTETCDIR] [–astmoddir ASTMODDIR] [–astvarlibdir ASTVARLIBDIR] [–astagidir ASTAGIDIR] [–astspooldir ASTSPOOLDIR] [–astrundir ASTRUNDIR] [–astlogdir ASTLOGDIR] [–ampbin AMPBIN] [–ampsbin AMPSBIN] [–ampcgibin AMPCGIBIN] [–ampplayback AMPPLAYBACK] [-r|–rootdb] [-f|–force]

Fixed now

Finally! Thankyou!

finally

Sucessfully Finished! :grin:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.