Can not access gui for freepbx-14 installed by source CentOS 7

Hello:
I followed the link exactly:
Installing FreePBX 14 on CentOS 7 - FreePBX OpenSource Project - Documentation
and all steps are correct, after run “./install -n”

Done. All modules installed.
Updating Hooks…Done
Done installing modules
Taking too long? Customize the chown command, See http://wiki.freepbx.org/display/FOP/FreePBX+Chown+Conf
Setting Permissions…
Collecting Files…Done
15410/15410 [============================] 100%
Finished setting permissions
Generating default configurations…
Finished generating default configurations
Trusting FreePBX…Trusted
You have successfully installed FreePBX

It looks that I completed all steps with success, but the GUI shows me Apache only, no freepbx gui:

i suspect the freepbx code sets wrongly. Any suggestions?

Are the files in /var/www/html/admin? Have you tried goingto http://192…/admin to see if it’s working?

Hello:
Yes, admin folder is there

[[email protected] html]# ls
admin index.php robots.txt ucp
[[email protected] html]# cd admin
[[email protected] admin]# ls
ajax.php assets bootstrap.php config.php functions.inc.php helpers i18n images index.php libraries module-builtin.xml modules page.modules.php views
[[email protected] admin]# cd …
[[email protected] html]# ls -l
total 8
drwxrwxr-x 9 asterisk asterisk 287 May 4 19:11 admin
-rw-rw-r-- 1 asterisk asterisk 453 May 4 19:11 index.php
-rw-rw-r-- 1 asterisk asterisk 361 May 4 19:11 robots.txt
lrwxrwxrwx 1 asterisk asterisk 38 May 4 19:12 ucp -> /var/www/html/admin/modules/ucp/htdocs
[[email protected] html]#

when access 192.168.x.x/admin, it shows:
Forbidden

You don’t have permission to access /admin/ on this server.

Does seem like Apache is running as the asterisk user

Yes, But I exactly follow the gui without any error, unit the final step.

Simple check, show us your

ps aux|grep httpd

it will show us all how ‘exactly without error’ you did it.

Result:
[[email protected] conf]# ps aux|grep httpd
root 2509 0.6 0.3 221936 4960 ? Ss 20:44 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 2510 0.0 0.2 224020 3092 ? S 20:44 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 2511 0.0 0.2 224020 3092 ? S 20:44 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 2512 0.0 0.2 224020 3092 ? S 20:44 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 2513 0.0 0.2 224020 3092 ? S 20:44 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 2514 0.0 0.2 224020 3092 ? S 20:44 0:00 /usr/sbin/httpd -DFOREGROUND

[[email protected] conf]# systemctl status httpd.service
● httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
Active: active (running) since Fri 2017-05-05 20:44:28 EDT; 2min 56s ago
Docs: man:httpd(8)
man:apachectl(8)
Process: 2505 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=0/SUCCESS)
Main PID: 2509 (httpd)
Status: "Total requests: 5; Current requests/sec: 0; Current traffic: 0 B/sec"
CGroup: /system.slice/httpd.service
├─2509 /usr/sbin/httpd -DFOREGROUND
├─2510 /usr/sbin/httpd -DFOREGROUND
├─2511 /usr/sbin/httpd -DFOREGROUND
├─2512 /usr/sbin/httpd -DFOREGROUND
├─2513 /usr/sbin/httpd -DFOREGROUND
├─2517 /usr/sbin/httpd -DFOREGROUND
├─2518 /usr/sbin/httpd -DFOREGROUND
├─2519 /usr/sbin/httpd -DFOREGROUND
├─2520 /usr/sbin/httpd -DFOREGROUND
├─2521 /usr/sbin/httpd -DFOREGROUND
└─2522 /usr/sbin/httpd -DFOREGROUND

May 05 20:44:28 localhost.localdomain systemd[1]: Starting The Apache HTTP Server…
May 05 20:44:28 localhost.localdomain httpd[2509]: AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using localhost.lo…s message
May 05 20:44:28 localhost.localdomain systemd[1]: Started The Apache HTTP Server.
Hint: Some lines were ellipsized, use -l to show in full.

thanks.

FreePBX installed by source:
[[email protected] html]# ls -l
total 8
drwxrwxr-x 9 asterisk asterisk 287 May 4 19:11 admin
-rw-rw-r-- 1 asterisk asterisk 453 May 4 19:11 index.php
-rw-rw-r-- 1 asterisk asterisk 361 May 4 19:11 robots.txt
lrwxrwxrwx 1 asterisk asterisk 38 May 4 19:12 ucp -> /var/www/html/admin/modules/ucp/htdocs

FreePBX installed by ISO:
[[email protected] html]# ls -l
total 24
drwxr-xr-x. 9 asterisk asterisk 4096 Dec 2 20:26 admin
lrwxrwxrwx. 1 asterisk asterisk 36 Dec 2 20:26 cxpanel -> /var/www/html/admin/modules/cxpanel/
drwxr-xr-x. 2 asterisk asterisk 4096 Dec 2 20:30 digium_phones
-rw-r–r--. 1 asterisk asterisk 453 Dec 2 20:15 index.php
drwxr-xr-x. 2 asterisk asterisk 4096 Dec 2 20:26 restapi
drwxr-xr-x. 2 asterisk asterisk 4096 Dec 2 20:30 restapps
-rw-r–r--. 1 asterisk asterisk 361 Dec 2 20:15 robots.txt
lrwxrwxrwx. 1 asterisk asterisk 38 Dec 2 20:26 ucp -> /var/www/html/admin/modules/ucp/htdocs
lrwxrwxrwx. 1 asterisk asterisk 47 Dec 2 20:26 wcb.php -> /var/www/html/admin/modules/webcallback/wcb.php
[[email protected] html]# ifconfig

thanks.

Hello:
Any suggestion? I installed three times for freepbx-14 with centos-7, all of them shows same problems.
/install -n shows sucess:

Done. All modules installed.
Updating Hooks…Done
Done installing modules
Taking too long? Customize the chown command, See http://wiki.freepbx.org/display/FOP/FreePBX+Chown+Conf
Setting Permissions…
Collecting Files…Done
15410/15410 [============================] 100%
Finished setting permissions
Generating default configurations…
Finished generating default configurations
Trusting FreePBX…Trusted
You have successfully installed FreePBX
[[email protected] freepbx]#

--------------------------access freepbx IP/admin----------
Forbidden

You don’t have permission to access /admin/ on this server.
---------------------------/var/log----------------------------------
this message
[Tue May 09 03:48:10.630845 2017] [auth_digest:notice] [pid 2527] AH01757: generating secret for digest authentication …
[Tue May 09 03:48:10.631279 2017] [lbmethod_heartbeat:notice] [pid 2527] AH02282: No slotmem from mod_heartmonitor
[Tue May 09 03:48:10.632904 2017] [mpm_prefork:notice] [pid 2527] AH00163: Apache/2.4.6 (CentOS) configured – resuming normal operations
[Tue May 09 03:48:10.632923 2017] [core:notice] [pid 2527] AH00094: Command line: ‘/usr/sbin/httpd -D FOREGROUND’
[Tue May 09 03:52:16.951230 2017] [mpm_prefork:notice] [pid 2527] AH00170: caught SIGWINCH, shutting down gracefully
[Tue May 09 03:52:18.020408 2017] [suexec:notice] [pid 2690] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using localhost.localdomain. Set the ‘ServerName’ directive globally to suppress this message
[Tue May 09 03:52:18.028017 2017] [auth_digest:notice] [pid 2690] AH01757: generating secret for digest authentication …
[Tue May 09 03:52:18.028455 2017] [lbmethod_heartbeat:notice] [pid 2690] AH02282: No slotmem from mod_heartmonitor
[Tue May 09 03:52:18.030103 2017] [mpm_prefork:notice] [pid 2690] AH00163: Apache/2.4.6 (CentOS) configured – resuming normal operations
[Tue May 09 03:52:18.030123 2017] [core:notice] [pid 2690] AH00094: Command line: ‘/usr/sbin/httpd -D FOREGROUND’
[Tue May 09 03:52:29.768218 2017] [authz_core:error] [pid 2691] [client 192.168.1.136:58178] AH01630: client denied by server configuration: /var/www/html/admin/index.html
[Tue May 09 03:52:32.652103 2017] [authz_core:error] [pid 2691] [client 192.168.1.136:58178] AH01630: client denied by server configuration: /var/www/html/admin/index.html
[Tue May 09 03:52:33.374007 2017] [authz_core:error] [pid 2691] [client 192.168.1.136:58178] AH01630: client denied by server configuration: /var/www/html/admin/index.html
[Tue May 09 03:52:37.906001 2017] [autoindex:error] [pid 2693] [client 192.168.1.136:58182] AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html) found, and server-generated directory index forbidden by Options directive

------------------------------httpd.conf--------------------------------

DirectoryIndex index.html index.php

I add index.php, but still got erros.

Stick with the FreePBX Distro where this is all handled properly. A source install is for advanced users who really know what they are doing.

1 Like

I checked httpd directory with FreePBX Distro, there is no freepbx.conf under config if installed by source, but there is a freepbx.conf in Dirstro. I do not know why.

You are installing freepbx manually. It’s not a distro system therefore distro specific files wont exist. The file you are looking for is distro only.

Manually installs are manual. You must do it yourself. If you want everything done for you then use the distro.

I just want to compare the difference to solve my problem. I manually installed withour any error, each step done successfully, but still got problem.
------httpd logs-----------------------
19] AH01630: client denied by server configuration: /var/www/html/admin/index.html

Only php files are allowed. You most likely need to edit your http conf file and set the right directory and file extensions that are allowed.

The guide you are following was run on an unmodified minimal centos 7 install two weeks ago.

Hi:
Could you share a workable httpd.conf file for centos-7?

The one that ships with centos7? Otherwise take one from the Distro.

My customer needs Sangoma E1 with chan_ss7, so I have to installed by source. I exactly follow the tutorial for Centos-7 withour any erros, but it does not work.

Please link the distro you are using and I will walk through it

Good luck with Chan SS7. It’s rarely used and not very complete and not supported by FreePBX.

Hi:
I have to install FreePBX GUI first and later install chan_ss7. I am using this link:
https://wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+CentOS+7
and manually install step by step, and there is no error, but there is AH0 1630 error from httpd log:


[Wed May 10 22:33:09.438642 2017] [auth_digest:notice] [pid 2419] AH01757: generating secret for digest authentication …
[Wed May 10 22:33:09.439054 2017] [lbmethod_heartbeat:notice] [pid 2419] AH02282: No slotmem from mod_heartmonitor
[Wed May 10 22:33:09.440570 2017] [mpm_prefork:notice] [pid 2419] AH00163: Apache/2.4.6 (CentOS) configured – resuming normal operations
[Wed May 10 22:33:09.440592 2017] [core:notice] [pid 2419] AH00094: Command line: ‘/usr/sbin/httpd -D FOREGROUND’
[Wed May 10 22:33:12.465342 2017] [authz_core:error] [pid 2420] [client 192.168.1.136:63329] AH01630: client denied by server configuration: /var/www/html/admin/index.html


the apache httpd.conf is this:
—httpd.conf -----------
<Directory “/var/www”>
AllowOverride All
# Allow open access:
Require all granted