Can i just change the IP Address?

Hello nice ppl… i’ve been using FreePBX for nearly a year and it’s working FLAWLESS!, so i must say i’m very happy with the distro.

This time i’m here to ask if i can just change the IP address of my FreeBPX box since i need to move it from the internal network to the DMZ so i can serve both… internal clients and external clients, and yes… i know it’s dangerous and all that scary stuff but i had done all that is recomended to avoid been part of a “use us to call the world for free and we pay your calls” stuff…

Ne way… just wondering if, instead of just change the IP address i can place a relay server at the DMZ and keep the “main” box untouched at the internal network.

Ty in advance!

If you’ve not specifically redefined the listening IP addresses in any of your configuration, i dont see why not :)…just change it since it is listening to (or some protocols, uses localhost…should not even need a restart actually.


Okay, changed the IP, swapped the NIC cable to the DMZ switch… so far so good UNTIL i tryed to place a phone call.

Just to be 100% sure there was nothing between the phone and the PBX i also installed a new phone at the DMZ, configured all the parameters and got it up and working. Picked up the phone, dial and after 10 secs the call just dropped… tryed like 5 more times with different numbers and got the same results.

Rolled back on the IP address change and moved back to the original switch and all was working perfect.

So… why does the call dropped at 10 secs since the ONLY thing i changed was the IP address?

Thinking about installing a brand new computer at the DMZ with FreePBX and use the PBX connected to the E1-PRI as a sip trunk.

ne1 help for me?

You did not mention what version of FreePBX, however I will assume it is version 2.8 or newer.

You need to go to SIP settings and set your externIP and localnet.

The PBX is trying to NAT since it’s outside the localnet and can’t deliver RTP packets. The RTP timer fires and the call is terminated.

You also should not have your PBX exposed, you should have a hardware or software firewall between the Internet and PBX.

You don’t have to DMZ, just port forward udp 5060 and your RTP ports (UDP 10000-20000 by default). Then go to asterisk sip settings and set nat to yes and enter you public and local ip info. After that you should be good to go.