Can Dynamic Agent be of type SIP?

Hi,
Our reporting software (Asternic Call Center Stats 2) require us to have extensions of type SIP (not local) and use feature codes when transferring calls in order to catch transferred calls in the reports.

Is it possible to have Dynamic Agents prefixed with S (e.g. S100,0) in the Dynamic Agents listing? I´ve tried, but the extension type gets handled as an agent.
When I put the extension in the Static Agents listing, everything works, except I cannot pause the extension. Unfortunately the pause/DND function is a must in our call center.

Version is FreePBX 14.0.13.26. Asterisk 13.27.1

Sorry for possibly bad explanation.
Thanks and best regards,
Janne

While the agents are set as ‘static’ have you tried using/creating a feature code to pause the agent?
Try ‘*46’ . You can also use *46XXXX where XXXX is the queue number (you can also pause OTHER queue members with *46*YYY*XXXX where ‘YYY’ is the extension you want to pause).

Thank you @el_jerry for your reply. I have tried all of the suggestions you made (and the voice tells me that pause is activated), but calls still get offered on the soft-phone of the agent (ringing).

If you’re not using the FreePBX methods to login dyamic agents into queues, then I would not expect the pause to work. What is the output of queue show xxxx where the x’s are the queue number?

For testing, I have configured only extension 100 as Static Agent of type SIP. The rest are dynamic. This is the output:

AsteriskPrim*CLI> queue show 111
111 has 0 calls (max unlimited) in ‘ringall’ strategy (9s holdtime, 20s talktime), W:4, C:28, A:29, SL:96.4% within 60s
Members:
Testuser (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (dynamic) (Not in use) has taken no calls yet
Pia S (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (dynamic) (Busy) has taken 400 calls (last was 187908 secs ago)
Pia (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (dynamic) (Busy) has taken 131 calls (last was 188624 secs ago)
Rea (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (dynamic) (Busy) has taken 172 calls (last was 265890 secs ago)
Tony (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (dynamic) (Busy) has taken 345 calls (last was 176104 secs ago)
Mari (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (dynamic) (Busy) has taken 448 calls (last was 177242 secs ago)
Jari (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (dynamic) (Busy) has taken 361 calls (last was 179585 secs ago)
Carina (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (dynamic) (Busy) has taken 190 calls (last was 273115 secs ago)
SIP/100 (ringinuse enabled) (Not in use) has taken 1 calls (last was 5 secs ago)
No Callers

I think I will do this programmatically in the agent´s desktop application. I´ll change the application to ignore the on-offering trigger when the agent has put herself as do not disturb. That means that the extensions is still “ringing”, but it does not show it to the agent.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.