Calls out have no audio (either end), all internal and incoming calls get busy signal


This is my first post in the forum, so if I am doing anything wrong, or could be doing it better please let me know.
Lawrence LaPlue
(tried to follow these ( suggestions)

I recently (Dec 2010) setup a FreePBX server with 5 Polycom 500 SIP phones
I used a PBXIn a Flash Distro (Purple) 1.7.9
FreePBX ver:
Asterisk ver: 1.8.0
CentOS ver: 5.5

We set it up on a DSL line, and (with significant help from this forum, and others)got everything working in a way we were satisfied with.

However, our fax machine was on the same line as the DSL and caused problems.

Last week we changed from the DSL to a fibernet line and had to change our router
from the DSL to an EnGenius ESR9850 (incoming ‘fibernet’ connection is technically Dynamic, but the ISP guarantees the IP address so it works like a static).

Our SIP Trunks are provided by SIPStation and we used the SIPStation module to configure everything initially.

Since we have updated the router, we have not been able to get calling set up the way we want.

Outgoing calls will ring the intended phone, but when the call answers there is no audio – either direction.
When that phone tries to call back, the call goes straight to voicemail.
When any of the 5 phones tries to call any other internal extension we get a busy signal.
When we try to dial in for voicemail (*98) we get nothing.

It seems reasonable to me that this is some how a router issue (though I have since turned off the router’s firewall), but I don’t know
how to troubleshoot this issue any further.

I have tried looking through an Asterisk log during an incoming call, but don’t really know what I am looking at/for, and I am stumped.

Any help on this issue, or thoughts about additional troubleshooting steps I can take would be greatly appreciated.

PS - I have generated Asterisk outputs for: an attempt to dial voicemail (*98) with no answer, and an internal dial (from ext 200 to ext 300).

Sometimes starting completely from the beginning is the best way to solve things. Who knows if that and/or switching the router resolved the issue.

When you are using the asterisk sip settings within freepbx, it should override the sip_nat.conf (or at least that’s what its threatened to me).

Believe me, this is all new to me so I am not a wizard–I can only tell you what has worked for me.

Well, for whatever it’s worth:

I changed routers (from EnGenius 9850 to Cisco / Linksys E1000.
Re-forwarded the ports (5060 TCP/UDP, 10000-20000UDP)

Did a fresh FPBX install.

Updated all of the modules, and entered my SIP Station info.

Edited my settings in the Asterisk SIP Settings module.

Setup SIP extensions (all default settings)

And now appear to have 2-way audio on both inbound and outbound calls.

NOTE: NO EDITING OF ANY .conf FILES (which is what the prevailing SIP Station, FreePBX, Tri-Box, PBXIAF, et. al. wisdom indicates)

I’m not advanced enough know how to solve the issue but I was getting the same warning until I completely eased the contents of the sip_nat.conf file and let the asterisk sip settings module take care of the rest. I now have three IP phones and no audio issues.

For the other error message, it means something the the misc application section called FONmail doesn’t do anything. Maybe it was once working but someting in the past 16 minutes broke it. I often see this message when deleting or changing something. For instance, deleting a queue but leaving the IVR to show an extension going to the queue.

Just have a look at FONmail again.

I don’t know what this might have to do with my problem but I have just started getting the following notification on the FPBX System Status dashboard:

FreePBX Notices

Error There are 1 bad destinations

Misc Application: FONmail

Added 16 minutes ago

I have now redone the .conf edits explicitly as prescribed in this ( tutorial.
I have tried BOTH with and without the “Incoming Settings” for the trunk that they recommend.

I also changed the rtp.conf settings to include:

I am now getting the following red error message in my “Asterisk SIP Settings Module”:

Settings in /etc/asterisk/sip_nat.conf may override these. Those settings should be removed.


My audio problem remains the same: outbound calls are fine. Inbound callers can hear me, but I can’t hear them.

I alluded to this above, but wasn’t explicit, sorry.

My sip_nat.conf file is blank… I haven’t done any of the .conf file edits I have seen recommended b/c I did them on my previous install and had these audio issues, AND the Asterisk SIP Settings module gave me an ‘override’ message.

Here are a couple of screen shots of those settings (the last two pics) –

Do I need to just go ahead and edit the sip_nat.conf file anyway?


should be at /etc/asterisk/sip_nat.conf

On this install I have not edited any of any .conf files (Tools > Maintenance > Config Edit), since I have read conflicting information about whether to edit the .conf files or to use the management modules provided in this release of FreePBX, AND when I edited those files before I got a red warning message about overriding settings when I looked in the Asterisk SIP module (Tools > System Administration > Asterisk SIP Settings).

I am sorry for being such a newbie (its such a waste of time), but could you tell me where I would find the settings you are talking about?

I am familiar with navigating either through the command line, or web portal, but haven’t come across “Asterisk NAT” settings.

(and thanks for posting back!)

Post your Asterisk NAT configuration. You may have made a mistake.

I have reinstalled FreePBX (clean install yesterday) with up to date FreePBX (, CentOS (5.5), and Asterisk (

My router has ALG options (don’t really know what that does, but I have disabled all of the options – including SIP).
And I have forwarded TCP/UDP ports 5060-5070 and UDP ports 10000-20000 to my server.

I now have two way audio on outbound calls but on incoming calls the caller can hear me, but I can’t hear the caller.

I am pretty sure this is a router (or a PBX communicating with router) issue.
And I expect the answer is simple, but I have been round and round FreePBX, and voip-info posts concerning one way audio and have not found a corresponding solution.

The common theme seems to be ‘it’s a NAT issue’ – and previous experience with FreePBX (and no previous experience with this router) leads me to believe the issue is with the router…
But I don’t know what else to do/look for. I get the same audio problems whether the router’s firewall is on or off (as I would expect w/ the ports forwarded), and disabling NAT cuts off my ability to surf on the rest of the network.

This router seems to have hopes of being a ‘business grade’ piece of equipment with lots of editing ability, but I don’t know what else to try. :frowning:

For the DSL I forwarded 5060TCP and 10000-20000UDP to my PBX.

After trying that on the new router I have since expanded that to 5055TCP and UDP, and 10000-20000TCP and UDP (exposing my lack of firm understanding of the networking interface required for a successful PBX implementation, I know).

Are you saying that I need to open up ports to each phone on my sub-network?

This sounds like a router/firewall issue.

What ports, specifically, were opened for each phone?
Also read your asterisk log files in freepbx and at /var/logs/asterisk/full

Asterisk will tell you everything in that long for pages and pages.