Calls having errors in log, cannot make calls

I am seeing the following in the logs, and currently cannot make any outbound calls on my setup. Any ideas?

[2017-11-09 17:00:41] WARNING[21522][C-00000008] channel.c: No channel type registered for ‘SIP’
[2017-11-09 17:00:41] WARNING[21522][C-00000008] app_dial.c: Unable to create channel of type ‘SIP’ (cause 66 - Channel not implemented)
[2017-11-09 17:00:41] VERBOSE[21522][C-00000008] app_dial.c: Everyone is busy/congested at this time (1:0/0/1)
[2017-11-09 17:00:41] VERBOSE[21522][C-00000008] pbx.c: Executing [[email protected]:32] NoOp(“PJSIP/100-00000008”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 66”) in new stack

and[2017-11-09 17:00:34] VERBOSE[21384] config.c: Parsing ‘/etc/asterisk/iax_custom_post.conf’: Found
[2017-11-09 17:00:34] WARNING[21384] iax2/firmware.c: Error opening firmware directory ‘/var/lib/asterisk/firmware/iax’: No such file or directory
[2017-11-09 17:00:34] NOTICE[21384] iax2/provision.c: No IAX provisioning configuration found, IAX provisioning disabled.
[2017-11-09 17:00:34] VERBOSE[21384] loader.c: Reloading module ‘chan_dahdi.so’ (DAHDI Telephony w/PRI & SS7 & MFC/R2)
[2017-11-09 17:00:34] VERBOSE[21384] loader.c: Reloading module ‘res_adsi.so’ (ADSI Resource)
[2017-11-09 17:00:34] VERBOSE[21384] loader.c: Reloading module ‘res_pjsip_outbound_registration.so’ (PJSIP Outbound Registration Support)
[2017-11-09 17:00:34] ERROR[21384] res_pjsip_config_wizard.c: Unable to load config file ‘pjsip_wizard.conf’
[2017-11-09 17:00:34] VERBOSE[21384] loader.c: Reloading module ‘res_pjsip_notify.so’ (CLI/AMI PJSIP NOTIFY Suppor

Is this a restore from a previous version to a newer version? Perhaps going from a 32-Bit version to a 64-Bit version?

No, fresh install

That’s weird - I have seen this with an upgrade - Here:

app_dial.c: Unable to create channel of type ‘SIP’ (cause 66 - Channel not implemented)

Means that Chan-SIP is not loaded - Is this a Distro, or a scratch load of FreePBX on top of your own load?

Distro

Ok - do this then - grep /var/log/asterisk/full for lines relating to chan_sip - post it here - it’s not loading for a reason…

Can I use the log filter in the gui for this, I’m not very good with command line? The gui shows no matches though?

from the command line like so:

cd /usr/src
grep chan_sip /var/log/asterisk/full > chan_sip.log
nano -w chan_sip.log

and then copy and paste the results here.

I rebooted the box, and dont see those errors now, but now i see 2 other things, and just have dead air after dialing instead of saying all circuits busy

[2017-11-09 19:00:06] WARNING[2798] chan_sip.c: Retransmission timeout reached on transmission @sip.flowroute.com for seqno 102 (Critical Request) – See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 31999ms with no response

and

[2017-11-09 19:07:31] NOTICE[2798] chan_sip.c: – Registration for ‘@sip.flowroute.com’ timed out, trying again (Attempt #28)

I have had nothing but issues with SIP after putting in my pfsense box, i love PFsense, but this is frustrating

Hmmmm…from both the error messages above, you are definitely not having good luck with passing SIP through the PFSense - I haven’t messed with them in YEARS but I seem to remember that it had a SIP ALG (Application Layer Gateway) that tried to “Help” and like most ALG’s it only screwed it up - for testing purposes, if you are on defaults you need to pass SIP (Either UDP Port 5060 or 5160 - Look in Settings -> Asterisk SIP Settings under Chan SIP Settings and confirm what port it is using - new installs default to 5160) and RTP (Default is UDP 10000-19999 if you haven’t changed anything) to the box from the outside and then see where you are.

Also, a gotcha with new installs - Check under Admin -> System Admin -> Intrusion Detection and make sure you haven’t blocked your provider - it can happen with misconfiguration and then you are chasing your tail because no matter what you do, it will never work because they are blocked!

I have the ports forwarded and allowed through the firewall, I have static outbound Nat set for the ports, and no ups are banned in freepbx, I opened a ticket with flowroute to ensure they didn’t block my public ip for too many attempts.

Hi!

It is generally no longer recommended to use sipproxyd, there is a big warning in their wiki about this…

re: https://doc.pfsense.org/index.php/Siproxd_package

(top of the page…)

As I told you in this thread

Flowroute is harder to setup than some of the other providers as they don’t proxy RTP traffic.

As I asked in that other thread, do you limit outbound communications with your firewall?

I do (with my pfSense firewall) and had this into account…

I am not sure which one of my providers proxy or don’t proxy RTP traffic now but Flowroute is the first one I encountered which forced me to globally permit RTP traffic…

Traffic to SIP ports has an ACL that lists all of my ITSPs servers, RTP traffic has no ACL at all…

Now your problem is not with RTP traffic but SIP but the RTP issue with Flowroute is something to keep in mind.

pfSense works wonderfully for me with SIP but I have a separate IP for my PBX. Is your FreePBX system on the same network as the LAN and sharing its IP or did you put in in a different subnet with different firewall rules (ie a real DMZ, not a consumer router defition of one).

How are you setted up?

Have you looked at pfSense firewall logs to see if it is actually the pfSense firewall blocking the SIP traffic?

Good luck and have a nice day!

Nick

I have mine nated with a single public ip for all internet traffic, and it is not on its own network/dmz. I will see if there is anything in the firewall logs

I saw that snort had an ip for flowroute blocked, unblocked and cleared states and still not working. Testing by looking through firewall and freepbx logs while making a call to see if issue is different now

Ok I think I found it, I keep seeing after a couple successful calls, in the firewall a rule called “block snort2c hosts” is blocking my sip ports. I’m not sure where this is or how to disable it

I see it is being blocked saying “(spp_sip) Maximum dialogs within a session reached” Im not sure how to fix this?

I think i fixed it, i didnt realize there was a dropdown for the WAN rules in snort, i went to the preprocessor rules and disabled the SIP maximum dialogs rule, and seems to be working now. But im still having issues with inbound, so i will try to work through this and see if i can also correct that.

ok now the calls can complete, but no audio

Haha i just realized how many updates i have, calls are working, but some have audio and some do not. I have ports 10000-20000 forwarded to my PBX, and have them set as static ports on Nat. Any ideas?