Calls from CUCM to Freepbx with Sip Trunk


(Julio) #1

Hi everyone

I need to integrate a Cisco Unified Call Manager 8.6 (CUCM) to Freebpx 15.0.17.34 with a Sip Trunk
Already I have set my sip trunk Freebpx to CUCM like this

Trunk name: To_CUCM
Outgoing
context=from-internal
host=10.X.Y.Z
type=friend
qualify=yes
dtmfmode=rfc2833
disallow=all
allow=ulaw&alaw
nat=no
insecure=very
port=5060

incoming
type=friend
context=from-trunk
host=10.X.Y.Z
dtmfmode=rfc2833
disallow=all
allow=ulaw&alaw
nat=no
canreinvite=no
qualify=yes

And outbound routes

Also I watch this video about Sangoma and CUCM Sip trunk, but Cisco Ip Phone CP-7945G and Zoiper Softphone they can call between them but they don’t heard anything

So please Someone can help me about this ?


(Jared Busch) #2

Assuming you are on a normal FreePBX 15 setup, pjsip is on port 5060. Use a pjsip trunk.


(David55) #3

Although it is true that new systems should use pjsip, and the port number of chan_sip is non standard when both are enabled, …

You don’t need separate inbound and outbound definitions. They should be type=peer, not type=friend, to avoid security breaches, if nothing else. insecure=very is an obsolete way of saying insecure=port,invite. From practical experience I can tell you you do not need insecure=port. As you have no shared secret, insecure=invite does nothing. Also, I would imagine that, if CUCM supports authentication, it should support it in both directions, so I doubt that insecure=invite would be good practice, even with a secret. In any case, insecure only affects incoming calls, so, if your outgoing section really is outgoing only, which is not necessarily what will actually happen, it is useless there.

We always left nat as default with CUCM, and I can see no reason to believe that default is not appropriate here.

CUCM definitely does support direct media re-INVITEs, so it is unlikely that there is a good reason for specifying canreinvite=no (although it should actually be specified using the current name, directmedia), unless your network routing doesn’t allow your extensions to directly communicate with the CUCM. If you are going to use it on separate incoming and outgoing settings, you should set it on both.


(Julio) #4

When I installed Freepbx I chose automatic installation, Settings are by default.


#5

Does using zoiper to make a call just to the asterisk box work correctly?
I would also do a call from the Cisco-based phone directly to the asterisk box and verify if the call works correctly or not.
For example, one can assign the ‘echo-test’ to an extension so one can test this way.


(David55) #6

If your network routing won’t support direct media, and the default is to enable it (I’m not sure what current versions of Asterisk and FreePBX do), you don’t have directmedia (canreinvite)=no for the outgoing configuration, but would need it in that case, and you may well find that incoming calls actually match the outgoing section, so it might not be turned off for incoming, either.

However, unless there are contraindications for pjsip, you would be better to start over with that, and to try to understand what the settings actually mean and do.


(Jared Busch) #7

All of this means nothing because he has a default install with pjsip on port 5060. His attempt to use a sip trunk on 5060 will never work.

Again, just delete this sip trunk and make a pjsip trunk with no authentication.


(Julio) #8

Hi,

I deleted sip trunk with chan sip and I created a new one with pj sip. But it ocurrs the same. Calls
Cisco Ip Phone CP-7945G and Zoiper Softphone they can call between them but they don’t heard anything.


(Jared Busch) #9

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Julio) #10

https://pastebin.freepbx.org/view/64787d19


#11

In Asterisk SIP settings, confirm that External Address and Local Networks are correctly set. If you change these, after Submit and Apply Config, you must restart Asterisk.

If that’s not your issue, at the Asterisk command prompt type
pjsip set logger on
make a failing test call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.


(Julio) #12

It works, I watched this video and set up Asterisk Sip Setting with networks from CUCM after that I restarted fwconsole and that’s it. It’s works…!!!


(system) closed #13

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.