Calls from 3CX to FreePBX not recorded

Good Morning Friends
I hope you are doing good and safe.

I am using FreePBX 15 . I have successfully configure trunk with third party IP PBX which is 3CX.

Inbound and outbound calls working 100% successfully between 3CX & FreePBX.

Calls originated from FreePBX to 3CX can be recorded 100% successfully

The issue that calls from 3CX to FreePBX is not recorded at all inspite of the fact that all FreePBX extensions has recording set to forced for internal ,external , inbound & outbound calls.

So kindly advice.

Best Regards

Share a call trace via pastebin of a problem call:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII

does your Inbound Route have recording set up as well?

do other calls record ok?

Good Morning Lorne
Thx for your replay . Kindly find the below pastebin of a problem call:

https://pastebin.freepbx.org/view/831c26d9

Best Regards

Good Morning Sholinaty
Thx for your replay . Kindly find my below notes:

  • Recording in Inbound route has been set to forced.
  • All other calls is being recording successfully including recording from FreePBX to 3CX.
  • The only issue happened when call received from 3CX to FreePBX . Call received and processed successfully but no recording.

Best Regards

Is 719777 a FreePBX endpoint in the [from-pstn] context?

Call trace shows an inbound call arriving in the from-pstn context but you don’t have an inbound route dedicated for this DID. The generic catchall route does not seem to honor recording which comes as a surprise to me, that might be considered a bug, but with an easy work around, just use inbound routes with DIDs specified.

The call then goes direct to a trunk, bypassing any local extension on outbound routes, so there is no other place to enable call recording.

Hello Lorne
I have configure specific DID for inbound route but recording still not working .

Thx in advance and waiting for your feedback.

Best Regards

Hello Dicko
19777 is a short number in Egypt (external number ) . To be able to make external call , 7 is prepend to external number as our gateway is configured to identity any number start with 7 as external number and then remove 7 before forward it to PSTN.

Best Regards

Show us a call trace using the inbound route with a DID. The one provided is using a catchall route.

Hello Lorne
Here is a trace for a call after set DID for inbound route:

https://pastebin.freepbx.org/view/d39a1fb0

Best Regards

Line 24

[2021-10-22 01:27:03] VERBOSE[22077][C-00000011] pbx.c: Executing [[email protected]:1] NoOp("PJSIP/20081-00000025", "Starting recording check against dontcare") in new stack

Looks like recording on this inbound route is set to “Don’t Care”. As before, the call bypasses local extensions and outbound routes, so there is no other place to set call recording, it must be enabled in the inbound route.

Good Morning Lorne
Thx for your note and for trying to help me solve this issue . It was set to don’t care by mistake . Now it has set to Force but same issue happened . Here is the pastebin:

https://pastebin.freepbx.org/view/b5f27c55

The below also is the track for a call with the same issue . This call didn’t go through Inbound route as this is call from 3CX to internal extension of FreePBX

https://pastebin.freepbx.org/view/37d57217

Also as i shared in my original post , Calls from FreePBX to 3CX recorded successfully . So i am sharing here the trace for a call from FreePBX to 3CX that has been recorded successfully:

https://pastebin.freepbx.org/view/52c5aa71

So kindly advice.

Best Regards

This call trace: https://pastebin.freepbx.org/view/b5f27c55 2

Recording starts:

[2021-10-22 05:35:15] VERBOSE[8472][C-00000012] pbx.c: Executing [[email protected]:16] NoOp("PJSIP/20081-00000027", "Starting recording: in, 719777") in new stack
[2021-10-22 05:35:15] VERBOSE[8472][C-00000012] pbx.c: Executing [[email protected]:17] Set("PJSIP/20081-00000027", "__CALLFILENAME=in-719777-Ahmed-Sallam-20211022-053515-1634873715.45") in new stack
[2021-10-22 05:35:15] VERBOSE[8472][C-00000012] pbx.c: Executing [[email protected]:18] MixMonitor("PJSIP/20081-00000027", "2021/10/22/in-719777-Ahmed-Sallam-20211022-053515-1634873715.45.wav,abi(LOCAL_MIXMON_ID),") in new stack

recording ends 13 sec later:

[2021-10-22 05:35:28] VERBOSE[8473][C-00000012] app_mixmonitor.c: MixMonitor close filestream (mixed)
[2021-10-22 05:35:28] VERBOSE[8473][C-00000012] app_mixmonitor.c: End MixMonitor Recording PJSIP/20081-00000027

not seeing anything indicating the call recording failed

Good Afternoon Lorne
I have attached snapshot from CDR reporting where the call which i sent its trace ( https://pastebin.freepbx.org/view/b5f27c55 ) and has CALL-ID “1634873715.45” is not recorded.

So kindly advice.

Best Regards

Not showing in the CDR is not the same as not recorded. Check in /var/spool/asterisk/monitor/... the recording is there.

looks like the specific subfolder path is likely :
/var/spool/asterisk/monitor/2021/10/22/in-719777-Ahmed-Sallam-20211022-053515-1634873715.45.wav

Good Afternoon Colleagues
The problem has been solved . Thanks for suggestions . All recorded can be viewed Reports ==> Call Event Logging . It seems that Reports ==> CDR Reports has some bugs as recorded calls from 3CX to FreePBX not showed in CDR reports.

Thanks @sholinaty for your help and very special thank for @lgaetz for helping me step by step until case solved.

Best Regards

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.