Calls drop 30 Seconds When Static. When set Public Everything Works

Fellow freePBX’ers,

I have a freePBX box setup behind a pfSense firewall. The pfSense has a direct pubic IP (straight Motorola modem). No double NAT.

So for my freePBX settings I chose Static IP and entered when chose auto configure it places the public IP and the local network. Then save.

With this configuration when a call comes in it times out with:

[Mar 8 13:12:44] WARNING[3662] chan_sip.c: Retransmission timeout reached on transmission [email protected] for seqno 4736 (Critical Response) – See
Packet timed out after 32001ms with no response

My router is set correctly with 5060 and 10000-20000 UDP forwarded to my internal freepbx.

The strange thing is that when I set the sip settings to “Public” instead of Static of Dynamic then all calls work correctly.

Does anyone have any idea what is going on?



Ok, I guess this was addressed before in another post.

I would still like to sum up exactly what change worked for me incase someone else happens upon this.

  1. In pfSense go to System/Advanced/Firewall and CHECK “Disable Firewall Scrub”.
  2. Go to Firewall/NAT/Outbound and change to Manual.
  3. Make sure all three settings have "Static Port = YES"
    WAN * * 500 WAN address * YES
    WAN * * * WAN address * YES
    WAN * * * WAN address * YES
  4. Go to Diagnostics/States and Click “Reset States”.

All trafic is now working with no issues.
You do not have to take away the NAT forwarding.