CallerID sometimes not received from SPA3102

I’ve been running FreePBX for several years, mostly to block junk calls. My SPA3102 is connected to my landline and configured as a trunk in FreePBX. Everything works fine, EXCEPT sometimes CallerID isn’t received from the SPA3102 by FreePBX. I know there WAS valid CallerID info because it shows up on my phone that’s connected to the landline. But FreePBX gets “pstn1” as the CallerID (which is the Subscriber Information User ID on the PSTN Line tab of the SPA3102) and “UNKNOWN NAME” as the CNAM (which is the Subscriber Information Display Name on the same tab).

Most times CallerID comes across fine, but 10-20% of the time it comes in as pstn1/UNKNOWN NAME, which means a spam caller gets through. Blacklisting pstn1 isn’t an option because it will indiscriminately block calls that didn’t get CalerID from from the SPA, including valid calls.

Has anybody else run into this? I looked through the SPA configuration menus for anything that could possibly be tweaked, but all I found was Regional/Caller ID Method (set to “N.Amer,China”) and Caller ID FSK Standard (set to “bell 202”).

Any suggestions appreciated!

Found that I didn’t have the latest firmware for the SPA3102, so I have upgraded it to the latest. Will see if that makes any difference…

I doubt that this has anything to do with FreePBX – after a failed call, see what the SPA’s info page shows for ‘Last PSTN Caller’.

IMO, it’s likely that the SPA sometimes fails to parse the caller ID because of noise or signal level issues.

What country are you in? Is your landline a copper pair to the central office? If not, please explain (Digital Voice from ISP, Vonage box, etc.) Any non-voice devices on the line (alarm, fax, etc.)? If so, how are they connected? Any multi-line phones? DSL service? SPA firmware version?

Settings that may be relevant include Ring Threshold and Ring Validation Time. If high frequency noise is the culprit, a DSL filter at the SPA Line jack may help.

To troubleshoot, set Syslog Server and Debug Server to the private IP address of your PC, set Debug Level to 3, set SIP Debug Option for PSTN Line to full excl. OPT|NTFY|REG, set up a syslog server or Wireshark on your PC, log at least one successful and one failing call, see what is different.

If your landline service includes call forwarding, a workaround would be forwarding to a DID that comes into your PBX via SIP. This would likely also provide better voice quality. If it works well, you might consider ditching the landline and going all VoIP, or keeping only minimal landline service for most reliable access to emergency calling and as a backup.

Thanks for your reply Stewart. Yeah, I knew this wasn’t strictly a FreePBX issue, but hoped others who were using a Linksys SPA with their PBX might have had similar issues and knew how to fix.

I’m in the US, and it is a regular copper POTS line. There is an alarm system hooked up through an RJ31X. No DSL on the line.

Firmware was (I’m embarrassed to say) 3.3.6. I’ve now upgraded to 5.2.13.

I do have syslog and debug servers set to my PBX server.with debug level set to 2 and SIP Debug Option set to none. I’ll bump up debug level to 3 and set SIP Debug Option to full excl. OPT|NTFY|REG, and see if I can get any more useful debugging info in the log than what I’ve been getting with it set to 2 and none.

Will update this post when it happens again.

Given that you have already an analog phone and an alarm system on the circuit then it is possible that the RE of the line is a problem especially if the co is a long way away from the customer premises,

FSK is relatively easy to decode if using bell 202 , but often an alarm system has “line grabbing” circuitry to ensure that your calls can be dropped when it wants to call home or the big red truck guys, and if you are on the user side of that then that might be another reduction in signal, to diagnose I would first disconnect your analog phone, and see if anything improves, then perhaps look at your alarm system wiring and see if you did it in accordance with the manufacturers directions.

Thanks for the reply, Dicko. With this being sporadic, you might be right that it is a signal strength issue. I can’t unplug the phone, unfortunately. Calls on the POTS line don’t route through the PBX (it only intercepts inbound spam calls, and uses the line as an outbound trunk), so I need the phone on that line to make and receive calls.

Release notes on the SPA3102 firmware update did mention CallerID, so I’m hoping it will make a difference. But could take a week or two before I know for sure. If firmware didn’t fix and increased logging isn’t helpful, then I’ll try disconnecting all but one of the phones on that line and see what happens.

Perhaps move the phone to the FXS port on the 3102? You would get the best of both worlds.

I’m actually already using the FXS port for my 2nd line (voip line through the PBX).

If your “phone” is currently a two-line one, and properly presents CallerID, then in FreePBX add a prefix to the inbound call and ensure call-waiting is enabled, pretty well same function, just less wiring and removes any extraneous loading on your land-line.

It is a 2-line analog phone. But not sure I understand what you mean. Do you mean send both VOIP and POTS incoming calls through the FXS port on the 3102, adding a prefix to one of them so I can tell which line is ringing? That would work, but only 1 of the 2 lines would be connected on the 2-line phone, so couldn’t have 2 calls going at once. Or am I misunderstanding what you mean?

Yes, you can only speak to one, at one time personally I find that’s all I can handle :slight_smile: , the other one would have to be put on hold, generally a hook flash would switch between them, you could also forward or conference as you wish, but it would definitely reduce any load on the FXO.

That was asked in my first post in this thread but went unanswered. Many multi-line phones have unwanted electrical coupling between the lines, which could be causing your issue. It’s usually audible as a hum, buzz or crackling noise. Make a call on the POTS line from the phone and have the remote party be silent. While listening carefully, unplug the other line (that’s connected to the SPA FXS port) and see whether that causes the call to get quieter (or noisier when you plug the cord back in).

If you can’t find (or can’t fix) the trouble, here is a possible workaround: When an ‘anonymous’ call comes in, the PBX sends it to an IVR with announcement “For Ralph, please press 7”. If the correct key is not pressed within 5 seconds, send it to voicemail or drop the call. On a correct response, ring the FXS port.

Sorry, I missed the multi-line phone question. But I LIKE the IVR workaround.

I’ve had 3 calls so far since I upgraded the firmware, and so far no missing callerid data. I’ll need to receive another 30 or 40 calls with no lost data before I’ll call the firmware update the fix. But if it turns out that didn’t fix it, I will definitely take a look at the IVR solution. The IVR would have to forward valid calls from either line to my line #2 (phone connected to FXS on the SPA3102) since line #1 phones aren’t connected to the PBX, but that’s still not a bad solution if it only drops callerid data occasionally.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.