CallerID not being sent to trunk, MACRO

The issue im having with this specific trunk is that any call that is made, its made in this format, the caller id is not sent through to the trunk
i may think its to do with macro or something,

you must look at my CDR and pbx to understand better
if theres anyone that can resolve this, happy to do anydesk, screensharing to let you check and figure it out
also happy to pay as long as its fixed
[email protected]

Welcome to the forum. If you want to get assistance from the community, it’s conventional to show a call trace showing a problem call shared via pastebin. You can do this using the instructions on this page:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII

If you want to pay, one option is to contact Sangoma support using the support link at the top.

hi, i am new to this so didnt know how to post it

here is the pastebin to the call ,pastebin / vE7dCF3Z

please also see the screenshot of the call ,pasteboard / xKYKhtjSD1p6.png

the caller id is “dev09” <94996677> when it gets sent to the trunk
the trunk receives the call but send its through with its own ID because its not receiving information to what to display. blank ID

I’ve added URL permission to your acct, can you share the actual url pls?

QFT:
Wed, 11 May 2022 16:07 1652285254.59 "dev09" <94996677> <+447543912828> Dial 0 - Pastebin.com and Pasteboard - Uploaded Image

But what’s needed is the Asterisk log for the call preferably including SIP trace.

Read the linked page for instructions to share a call trace. There should be dozens to hundreds of lines.

Do you have the Outbound CID for extension 94996677 set to a mobile number, or is this a call forwarded to a mobile where you are trying to preserve the caller ID of the original caller?

In either case, there are (at least) four possibilities:

  1. The trunking provider does not allow you to send a number that’s not yours. In some cases, you can fix this by signing a special agreement, or (if the 0754 number is your own mobile) verifying that number with them.
  2. The number is being presented in the wrong format. Look at how the provider sends caller ID on an incoming call, and use the same format for outgoing.
  3. The caller ID is being sent in the wrong header. Check whether the provider wants it in From, P-Asserted Identity or Remote-Party-ID and set up the trunk accordingly.
  4. The provider may require including a Diversion header when sending a number other than a DDI you have with them.

I made a test call but it went to EE voicemail. Did the expected 0754 caller ID show?

Yes I received the call my
Number is on Do not disturb that’s why it went voice Mail number was 07543

The trunk does support any caller Id as long as the format is 44….
When we add a different trunk the call does get sent through in the right format
It’s just with this specific trunk it sends as extension, extension is the user account which does set up a number I won’t call without a number

I took a look at ispoof and was not impressed: expensive, lack of documentation, inflexible payment means, seem to be mostly used by nefarious characters.

If it meets your needs, you may be better served with a provider such as Voxbeam (what I used for the test) or AnveoDirect. Both will provide a small credit at signup, so you can test without making a payment. If you don’t see that, open a ticket and ask.

If you still want to get ispoof working, I suggest using E.164 format without the + (that’s what they show in their video) and put it in the display name as well. For example, as a test, set Outbound CID for your extension to “447543912828” <4475438912828> and also set Send RPID/PAI for the Trunk to Both. (Make sure that the Outbound Route doesn’t override the extension and CID Options for the Trunk is Allow Any CID.)

If no luck, at the Asterisk command prompt, type
pjsip set logger on
make a failing test call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.

hi, i am really struggling to get things up and running correct, can you check it out using rdp?

I don’t see anywhere where you’ve shared a call trace using the instructions linked above.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.