Callerid lookup sources

i have freepbx FreePBX 2.7.0.8
and my module callerid lookup sources doesn’t work
i have on Source: External CID Lookup
Source type: http
host: www.altshop.ro
Port:
Username:
Password:
Path: /freepbx_get_name.php
Query: ?nr=[NUMBER]

so will go to www.altshop.ro/freepbx_get_name.php?nr=0768334770
and the result must be
SERIA VIOREL

i use softphone EYEBEAM but i receive only the number and does’nt display the name

[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:1] Set(“SIP/GXW-PSTN-TRUNK-00000080”, “AMPUSER=0748103104”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:2] GotoIf(“SIP/GXW-PSTN-TRUNK-00000080”, “0?report”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:3] ExecIf(“SIP/GXW-PSTN-TRUNK-00000080”, “0?Set(REALCALLERIDNUM=0748103104)”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:4] Set(“SIP/GXW-PSTN-TRUNK-00000080”, “AMPUSER=”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:5] Set(“SIP/GXW-PSTN-TRUNK-00000080”, “AMPUSERCIDNAME=”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:6] GotoIf(“SIP/GXW-PSTN-TRUNK-00000080”, “1?report”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Goto (macro-user-callerid,s,9)
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:9] GotoIf(“SIP/GXW-PSTN-TRUNK-00000080”, “0?continue”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:10] Set(“SIP/GXW-PSTN-TRUNK-00000080”, “__TTL=63”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:11] GotoIf(“SIP/GXW-PSTN-TRUNK-00000080”, “1?continue”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Goto (macro-user-callerid,s,18)
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:18] Set(“SIP/GXW-PSTN-TRUNK-00000080”, “CALLERID(number)=0748103104”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:19] Set(“SIP/GXW-PSTN-TRUNK-00000080”, “CALLERID(name)=”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:20] NoOp(“SIP/GXW-PSTN-TRUNK-00000080”, “Using CallerID “” <0748103104>”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:3] GotoIf(“SIP/GXW-PSTN-TRUNK-00000080”, “0?skipdb”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:4] GotoIf(“SIP/GXW-PSTN-TRUNK-00000080”, “0?skipov”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:5] Set(“SIP/GXW-PSTN-TRUNK-00000080”, “__NODEST=”) in new stack
[Feb 23 10:21:37] VERBOSE[9868] pbx.c: – Executing [[email protected]:6] Set(“SIP/GXW-PSTN-TRUNK-00000080”, “__BLKVM_OVERRIDE=BLKVM/4001/SIP/GXW-PSTN-TRUNK-00000080”) in new stack

Ok, that log was also useless and I have erased it.

You have a context called “incoming”, where do you set that up?

the cidlookup didn’t apear, i think that this not execute the lookup, but why ?
i check on inbound routes
and on all incoming any DID / any CID
on CID Lookup Source, the source is selected corectly

You need to look in the log for the start of the call when it enters the system.
This is a log from my system with caller id lookup:

-- Executing [[email protected]:1] NoOp("SIP/5060-00031afb", "Received incoming SIP connection from unknown peer to 040111111") in new stack
-- Executing [[email protected]:2] Set("SIP/5060-00031afb", "DID=040111111") in new stack
-- Executing [[email protected]:3] Goto("SIP/5060-00031afb", "s|1") in new stack
 -- Goto (from-sip-external,s,1)
-- Executing [[email protected]:1] GotoIf("SIP/5060-00031afb", "1?checklang:noanonymous") in new stack
-- Goto (from-sip-external,s,2)
-- Executing [[email protected]:2] GotoIf("SIP/5060-00031afb", "1?setlanguage:from-trunk|040111111|1") in new stack
-- Goto (from-sip-external,s,3)
-- Executing [[email protected]:3] Set("SIP/5060-00031afb", "CHANNEL(language)=se") in new stack
-- Executing [[email protected]:4] Goto("SIP/5060-00031afb", "from-trunk|040111111|1") in new stack
-- Goto (from-trunk,040111111,1)
-- Executing [[email protected]:1] Set("SIP/5060-00031afb", "__FROM_DID=040111111") in new stack
-- Executing [[email protected]:2] Gosub("SIP/5060-00031afb", "app-blacklist-check|s|1") in new stack
-- Executing [[email protected]:1] LookupBlacklist("SIP/5060-00031afb", "") in new stack
-- Executing [[email protected]:2] GotoIf("SIP/5060-00031afb", "0?blacklisted") in new stack
-- Executing [[email protected]:3] Set("SIP/5060-00031afb", "CALLED_BLACKLIST=1") in new stack
-- Executing [[email protected]:4] Return("SIP/5060-00031afb", "") in new stack
-- Executing [[email protected]:3] Gosub("SIP/5060-00031afb", "cidlookup|cidlookup_2|1") in new stack

Note that the call enters the system in from-sip-external then goes to from-trunk where it goes to cidlookup.

Please check your logs.

The above posted log is useless. You need to look at your log file from the beginning of the call to see if it calling the cidlookup code.

OK HERE IS THE ENTIRE LOG
(deleted by moderator)

Have you enabled CallerID in Inbound routes?

we didnt modify nothing in inbound routes
where to change this value ?
thanks for fast reply

we enabled but cannot make lookup

[Feb 23 13:10:47] VERBOSE[11079] res_agi.c: dialparties.agi: Starting New Dialparties.agi
[Feb 23 13:10:47] VERBOSE[11079] res_agi.c: dialparties.agi: Caller ID name is ‘unknown’ number is ‘0748103104’
[Feb 23 13:10:47] VERBOSE[11079] res_agi.c: dialparties.agi: Methodology of ring is ‘ringall’

[Feb 23 13:10:43] VERBOSE[11079] pbx.c: – Executing [[email protected]:18] Set(“SIP/GXW-PSTN-TRUNK-00000169”, “CALLERID(number)=0748103104”) in new stack
[Feb 23 13:10:43] VERBOSE[11079] pbx.c: – Executing [[email protected]:19] Set(“SIP/GXW-PSTN-TRUNK-00000169”, “CALLERID(name)=”) in new stack
[Feb 23 13:10:43] VERBOSE[11079] pbx.c: – Executing [[email protected]:20] NoOp(“SIP/GXW-PSTN-TRUNK-00000169”, “Using CallerID “” <0748103104>”) in new stack
[Feb 23 13:10:43] VERBOSE[11079] pbx.c: – Executing [[email protected]:3] GotoIf(“SIP/GXW-PSTN-TRUNK-00000169”, “0?skipdb”) in new stack
[Feb 23 13:10:43] VERBOSE[11079] pbx.c: – Executing [[email protected]:4] GotoIf(“SIP/GXW-PSTN-TRUNK-00000169”, “0?skipov”) in new stack
[Feb 23 13:10:43] VERBOSE[11079] pbx.c: – Executing [[email protected]:5] Set(“SIP/GXW-PSTN-TRUNK-00000169”, “__NODEST=”) in new stack