Caller ID Not working

Hi,

I am using asterisk 1.4.28 with freepbx 2.6 (Asterisknow1.5) and Wildcard TDM410P card. Everything is working fine except the caller ID of incoming call from PSTN line. The phone display is showing "Unknown" when there is an incoming call from PSTN.

My log file showing this while an incoming call on PSTN line:
tail -f /var/log/asterisk/full

[Dec 30 06:36:16] DEBUG[2559] dsp.c: dsp busy pattern set to 0,0
[Dec 30 06:36:16] VERBOSE[2715] logger.c: – Starting simple switch on ‘DAHDI/1-1’
[Dec 30 06:36:16] VERBOSE[2715] logger.c: – Executing [[email protected]:1] Set(“DAHDI/1-1”, “__FROM_DID=s”) in new stack
[Dec 30 06:36:16] VERBOSE[2715] logger.c: – Executing [[email protected]:2] Gosub(“DAHDI/1-1”, “app-blacklist-check|s|1”) in new stack
[Dec 30 06:36:16] VERBOSE[2715] logger.c: – Executing [[email protected]:1] LookupBlacklist(“DAHDI/1-1”, “”) in new stack
[Dec 30 06:36:16] VERBOSE[2715] logger.c: – Executing [[email protected]:2] GotoIf(“DAHDI/1-1”, “0?blacklisted”) in new stack
[Dec 30 06:36:16] VERBOSE[2715] logger.c: – Executing [[email protected]:3] Set(“DAHDI/1-1”, “CALLED_BLACKLIST=1”) in new stack
[Dec 30 06:36:16] VERBOSE[2715] logger.c: – Executing [[email protected]:4] Return(“DAHDI/1-1”, “”) in new stack
[Dec 30 06:36:16] VERBOSE[2715] logger.c: – Executing [[email protected]:3] ExecIf(“DAHDI/1-1”, “1 |Set|CALLERID(name)=”) in new stack
[Dec 30 06:36:16] VERBOSE[2715] logger.c: – Executing [[email protected]:4] Set(“DAHDI/1-1”, “FAX_RX=disabled”) in new stack
[Dec 30 06:36:16] VERBOSE[2715] logger.c: – Executing [[email protected]:5] Set(“DAHDI/1-1”, “__CALLINGPRES_SV=allowed_not_screened”) in new stack

My chan_dahdi.conf file is as like this.
vim /etc/asterisk/chan_dahdi.conf

[channels]
language=en
hanguponpolarityswitch=yes
answeronpolarityswitch=yes
busydetect=yes
busycount=3
callprogress=yes
callerid=asreceived
immediate=yes
cidsignalling=dtmf
cidstart=polarity
;cidstart=ring
useincomingcalleridonzaptransfer=yes
;cidsignalling=bell
; include dahdi extensions defined in FreePBX
#include chan_dahdi_additional.conf

; XTDM20B Port #1,2 plugged into PSTN
;AMPLABEL:Channel %c - Button %n

Please help me for fixing this issue. I am from India.

Regards,
Aruns

I ran into a similar problem with a client. I banged my head against the wall for about 3 days until I found out the analog trunks did not include callerid from the phone company so there was no callerid to report. Are you sure all of your incoming trunks have callerid and it is turned on?

There is an option to “Never Override CallerID” in the Zap/Dahdi trunk menu. It is normally not selected. (Ignore the red circles - the image was used for something else)

Hi,

I don’t have such an option in my trunk menu.

Thanks,
Arun S

;cidstart=polarity
cidstart=ring

1 Like

Hi,

I tried both settings. But no result

when i use "cidstart=ring"
I am getting this in my asterisk log

[Jan 7 09:31:13] VERBOSE[7129] logger.c: – Starting simple switch on ‘DAHDI/1-1’
[Jan 7 09:31:14] ERROR[7129] callerid.c: No start bit found in fsk data.
[Jan 7 09:31:14] WARNING[7129] chan_dahdi.c: CallerID feed failed: Success
[Jan 7 09:31:14] WARNING[7129] chan_dahdi.c: CallerID returned with error on channel ‘DAHDI/1-1’
[Jan 7 09:31:14] VERBOSE[7129] logger.c: – Executing [[email protected]:1] Wait(“DAHDI/1-1”, “5”) in new stack
[Jan 7 09:31:19] VERBOSE[7129] logger.c: – Executing [[email protected]:2] Gosub(“DAHDI/1-1”, “app-blacklist-check|s|1”) in new stack
[Jan 7 09:31:19] VERBOSE[7129] logger.c: – Executing [[email protected]:1] LookupBlacklist(“DAHDI/1-1”, “”) in new stack
[Jan 7 09:31:19] WARNING[7129] app_lookupblacklist.c: LookupBlacklist is deprecated. Please use ${BLACKLIST()} instead.
[Jan 7 09:31:19] VERBOSE[7129] logger.c: – Executing [[email protected]:2] GotoIf(“DAHDI/1-1”, “0?blacklisted”) in new stack

And when i use “cidstart=polarity” I am getting this in my log

[Jan 7 09:35:16] VERBOSE[7300] logger.c: – Starting simple switch on ‘DAHDI/1-1’
[Jan 7 09:35:16] VERBOSE[7300] logger.c: – Executing [[email protected]:1] Wait(“DAHDI/1-1”, “5”) in new stack
[Jan 7 09:35:22] VERBOSE[7300] logger.c: – Executing [[email protected]:2] Gosub(“DAHDI/1-1”, “app-blacklist-check|s|1”) in new stack
[Jan 7 09:35:22] VERBOSE[7300] logger.c: – Executing [[email protected]:1] LookupBlacklist(“DAHDI/1-1”, “”) in new stack
[Jan 7 09:35:22] WARNING[7300] app_lookupblacklist.c: LookupBlacklist is deprecated. Please use ${BLACKLIST()} instead.
[Jan 7 09:35:22] VERBOSE[7300] logger.c: – Executing [[email protected]:2] GotoIf(“DAHDI/1-1”, “0?blacklisted”) in new stack
[Jan 7 09:35:22] VERBOSE[7300] logger.c: – Executing [[email protected]:3] Set(“DAHDI/1-1”, “CALLED_BLACKLIST=1”) in new stack
[Jan 7 09:35:22] VERBOSE[7300] logger.c: – Executing [[email protected]:4] Return(“DAHDI/1-1”, “”) in new stack
[Jan 7 09:35:22] VERBOSE[7300] logger.c: – Executing [[email protected]:3] ExecIf(“DAHDI/1-1”, “1 |Set|CALLERID(name)=”) in ne

And I tried another option “cidstart=polarity_IN”

Then my log shows this…

Jan 7 09:43:13] VERBOSE[7642] logger.c: – Starting simple switch on ‘DAHDI/1-1’
[Jan 7 09:43:14] NOTICE[7642] chan_dahdi.c: Got event 18 (Ring Begin)…
[Jan 7 09:43:15] NOTICE[7642] chan_dahdi.c: Got event 2 (Ring/Answered)…
[Jan 7 09:43:17] NOTICE[7642] chan_dahdi.c: Got event 18 (Ring Begin)…
[Jan 7 09:43:17] VERBOSE[7642] logger.c: – Executing [[email protected]:1] Wait(“DAHDI/1-1”, “5”) in new stack
[Jan 7 09:43:22] VERBOSE[7642] logger.c: – Executing [[email protected]:2] Gosub(“DAHDI/1-1”, “app-blacklist-check|s|1”) in new stack
[Jan 7 09:43:22] VERBOSE[7642] logger.c: – Executing [[email protected]:1] LookupBlacklist(“DAHDI/1-1”, “”) in new stack
[Jan 7 09:43:22] WARNING[7642] app_lookupblacklist.c: LookupBlacklist is deprecated. Please use ${BLACKLIST()} instead.
[Jan 7 09:43:22] VERBOSE[7642] logger.c: – Executing [[email protected]:2] GotoIf(“DAHDI/1-1”, “0?blacklisted”) in new stack

In all these settings I dont have any CID output.

Thanks,
Arun S

i am also faced the same problem for 4month and i got succeded in getting callerid but after every 8 or 10 th call i am missing caller id.

if you use airtel service it works good
if you use bsnl service then its a big headace.(i am using bsnl)

the solution is to use ##DTMF to FSK converter by FINTEL.##
cidstart=ring
cidsignalling=bell

the card made for fsk only ,our signal is dtmf.so u need to conver it.
it is around rs 350 to 400 only
it will look like spliter used for broadband connection .be carefull the shopkeeper
will cheat you by giving the normal spliter .