Caller ID issues with 2.9

Issue 1
When we make calls between phones on the same FreePBX 2.9.0rc1.3 the caller id function does not work for the caller. We have Cisco 7940 phone running SIP firmware P0S3-8-12-00. When the caller dials the extension of the person you want to call, you only see the extension even after the call is established. The person you called sees the callers name so that side works internally. We are switching from Cisco Call Manager and with that system it does show the name. Is it possible to have the name show for the person you are calling internally?

Issue 2
The Caller ID name shown has no spaces between in the words. On each extension we have the full name properly formatted with a space. What might I need to change to have the display name correct on the phones?

Issue 3
Inbound caller id from PRI does not show on the phones only the number is displayed. I have checked on the router and the caller id name is there and should be sent to FreePBX via the SIP trunk. On our line we have telco provided caller id information. In the Asterisk CLI I see the CALLERID(number)=8151234567") CALLERID(name)="). What might I need to change to have the name show on the phones?

– Executing [[email protected]:1] Macro(“SIP/CM5-00000032”, “user-callerid,LIMIT,”) in new stack
– Executing [[email protected]:1] Set(“SIP/CM5-00000032”, “AMPUSER=8151234567”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/CM5-00000032”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/CM5-00000032”, “1?Set(REALCALLERIDNUM=8151234567)”) in new stack
– Executing [[email protected]:4] Set(“SIP/CM5-00000032”, “AMPUSER=”) in new stack
– Executing [[email protected]:5] Set(“SIP/CM5-00000032”, “AMPUSERCIDNAME=”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/CM5-00000032”, “1?report”) in new stack
– Goto (macro-user-callerid,s,12)
– Executing [[email protected]:12] GotoIf(“SIP/CM5-00000032”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,25)
– Executing [[email protected]:25] Set(“SIP/CM5-00000032”, “CALLERID(number)=8151234567”) in new stack
– Executing [[email protected]:26] Set(“SIP/CM5-00000032”, “CALLERID(name)=”) in new stack
– Executing [[email protected]:2] Set(“SIP/CM5-00000032”, “INTRACOMPANYROUTE=YES”) in new stack
– Executing [[email protected]:3] Set(“SIP/CM5-00000032”, “MOHCLASS=default”) in new stack
– Executing [[email protected]:4] Set(“SIP/CM5-00000032”, “_NODEST=”) in new stack
– Executing [[email protected]:5] Macro(“SIP/CM5-00000032”, “record-enable,OUT,”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/CM5-00000032”, “1?check”) in new stack

Hi A-Roby,

I might be off base here, just one day experience with FPBX 2.9 …

On the extensions page you can change some settings with regard to the remote CallerID, try changing the trust rpid and Send rpid settings, i suggest you start with the P-Asserted-ID

Keep in mind that the firmware should support the SIP headers :Remote-Parti-ID or P-Assterted-Identity

Also not all SIP trunk providers might be sending the CallerID Name trough the trunk.

take a SIP network trace and see what happens.

Good luck,
Richard

He is not using a SIP provider, it’s a SIP trunk to a router with a flex T1 card connected to a PRI.

As far as the connected line feature, what version of Asterisk are you running?

Asterisk (Ver. 1.6.2.11)

Asterisk 1.6.x does not have the connected line feature, it requires release 1.8

Sorry for missing the trunk thingie…

there is still no caller id displayed during the outbound call with FreePBX 2.9.0rc1.3 and Asterisk 1.8.3.2 on the Cisco 7940 phone running SIP firmware P0S3-8-12-00

Do you have the send and trust rpid parameters set properly?

Thank you SkykingOH. I have now been able to get the phones to display the caller id info between phones on the same server. This solves Issue 1, any thoughts on the other issues?
Under the extension the settings are
Trustrpid yes
Sendrpid send Remote-Party_ID header