Caller ID does not work. Paging and intercom

I recently set up a Cisco SPA3000 as a simple trunk and the caller ID was working showing me the phone number and the name of the line holder. however after redoing the set up after the recent update, the caller ID no longer works. Only shows the name Circuit (the name registered with the pstn line) and no additional information. How do I make the caller ID work again?

Also I have people that are bad at answering the phone, I have Cisco SPA phones and Polycom phones. Is there a way to page the phone with a unique number so that it will auto answer. I don’t want the phone to answer by it’s self with incoming calls. I need to only auto answer sometimes.

What update? What didn’t work after the update that caused you to redo anything? What did you redo?

Anyhow, either the SPA3000 isn’t sending the number or the PBX isn’t showing it. To find out which, at the Asterisk command prompt, type
pjsip set logger on
if the SPA3000 is on a pjsip trunk or
sip set debug on
if a chan_sip trunk.

Call in and look at the From header in the incoming INVITE.

If the number is not there, check in the 3000:
PSTN Answer Delay: 4
Caller ID Method: Bellcore
Caller ID FSK Standard: bell 202
If no luck, post screenshots for PSTN Line and Regional

If the From header does have the number, post screenshots of your trunk settings.

For intercom to extension 101, from another extension dial
If that doesn’t work, what happens? If you need to do this from an outside number, please provide details.

Issues solved, thanks very much.

Please post details:

What update caused trouble?
What did you do to recover that broke caller ID?
How did you solve the problem?

Update just meaning a new version of freePBX and all clean configs. The issue was solved by changing the answer delay time.
As a side question have you been able to get the outbound CID to work with this trunk and phone system?
Also this *80XXX does not work on the polycom phones, they ring 1 and a half times then goto busy. Works like a charm on the cisco phones. but calling any of the polycom phones does not work

You need to allow autoanswer on the phone.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.