Callcentric Setup Guide

I’m wondering if anyone has a guide to using FreePBX with Callcentric?

I’ve used the guide that they provide on their website and I am able to make and receive calls, but “Allow SIP Guests” & “Allow Anonymous Inbound SIP Calls” are both set to “Yes”.

I’m still learning about FreePBX/Asterisk, but it seems like I should have those set to “No” for security purposes. Is that true? What exactly are those settings properly used for?

Good morning, coreybrett.

I can’t help you with the Callcentric part, but you can get a brief explanation of the function of most options by hovering your mouse over the little circled “?” to the right of most (but not all) options. The circled “?” is very faint on my screen… I have to really look closely to see if it is there.

Settings->General Settings->Allow Anonymous Inbound SIP Calls carries a strong warning advising that you set it to “No” unless you know exactly what you are doing.

Settings->Asterisk SIP Settings->Allow SIP Guests says you can set it to “Yes” with Anonymous SIP Calls set to “No” and debug misconfigurations that make calls come into the system looking like guests. Not sure what that’s all about. :slight_smile:

I have both set to “No” and can’t really imagine setting either to “Yes” unless there is a really good reason that can’t be worked around some other way.

I suppose you could have one or both of those set to “Yes” if your installation caters to unknown customers who regularly call via SIP calls. I suppose that could be true if you use a commercial SIP service provider… never done that so don’t know what the requirements are.

Eric /

Thanks for your response, I am aware of the tool tips, but they do not really give me enough information.

My problem is that if I set these to “No” my incoming calls from Callcentric are bounced.

If “Allow SIP Guests” is set to “NO”, I get a Callcentric message [person not available] when calling from outside.

If “Allow Anonymous Inbound SIP Calls” is set to “NO”, I get an Asterisk message [number not in service] when calling from outside.

I’m trying to figure out what I need to change on my trunk settings to allow calls to be completed without setting ether of the settings in question to “YES”.

Currently, if I set both to “YES”, calls are able to come through.

Yeah, I sorta figured I wouldn’t be much help. :slight_smile:

Maybe the Callcentric folks can help. Surely you’re not the only Asterisk user that uses them.

I did contact them, but their solution was to select YES on those two options.
I’m guessing this is a “context” thing , but I’m a noob with Asterisk.

It’s not a context problem. You simply have to build matching peers to the SIP servers Callcentric will be sending you calls from.

They don’t provide an example for generic Asterisk?

They provide the following information.

I am trying to figure out how to setup a truck with them entirely via the FreePBX GUI in the most appropriate way.

Outgoing calls work fine, even with both options set to NO.
Incoming calls are the problem.

These links are PDFs of my current config.

Last time I checked you had to set Allow SIP Guests = yes for Callcentric. It might work initially if you set it to no but eventually it stops registering.

How do I adjust the FreePBX GUI settings to accept calls from a configured trunk without setting “Allow SIP Guests” & “Allow Anonymous Inbound SIP Calls” to “YES”.

From some of the other posts in this thread, it doesn’t seem that you can, necessarily, and it depends on the SIP service vendor…

I admit I’m an Asterisk/FreePBX noob, but that seem difficult to believe.

If the server is authenticating with Callcentric via SIP, why would it be considered a “guest” or “anonymous”?

Registration simply tells them where to send the call.

The inbound call is not matching your peer.

You should never ever set Allow Anonymous to Yes unless for very special reasons which you completely understand. Getting a trunk to work is not one of them.

Also, Allow Guests is NOT not not the same setting as Allow Anonymous. If you google it you will get the impression that it is but I can assure you it isn’t. Everyone who says that is wrong.

If only you spent as much time getting this forum to work properly so we could edit our own posts again as you do trying to correct me.

On the bright side, at least you cannot falsely accuse me of editing my posts so you can claim I was wrong about something I never even typed. Still laughing over that one.


Could you expand on that?
How would I make the peers match?
What is a peer?

Set allow anonymous = no and allowguests =yes which are defaults and then don’t worry about them. Those are the correct settings I can assure you. If that does not solve your problem then we will need more information.

I wouldn’t get hung up on the terminology.

When “Allow Anonymous Inbound SIP Calls” is set to “NO”, I get an Asterisk message [number not in service] when calling from outside.

Put the 177etc username in the trunk name box above peer details. That should help.

Didn’t change anything.