Call studders when another call rings in via ring group (ring-all)

I have a small office site with about 10 phones (Aastra/Mitel 6867i) with a cloud hosted FreePBX, where they have a ring group for inbound calls.
The problem they are having is when one member of the ring group is occupied on a call and another call comes in, the occupied call studders while the new call is ringing (ring-all).

I’ve tried convincing them that a queue would probably be better, however, they want to be able to quickly put a current call on hold to answer another incoming call (no agent time out or retry) … but also have it do a ring-all to all extensions in that office.

The both ends of the call hear the studder when a new call attempt rings.
“Skip Busy Agent” will not work because they need to be able to answer the incoming call.

Any ideas on how to illuminate this studder?

. The stutter is the phone ringing - just like it would be in a POTS phone. The fact that you don’t hear it doesn’t mean it isn’t there. Your thought process is correct, but (IMHO) your answer was incorrect

“Skip busy agent” should be set. If they want to put someone on hold and pick up another call, they can do that.

Put the client on hold.
Press “Pickup” to pick up the call from the ring group (they should all be in the same pickup group).
Answer that call.
Take the other caller when the intermediate call comes back.

ah… that might have been where I made my mistake.
When I enabled “Skip Busy Agent” I didn’t enable call pickup or make a call pickup button.
I’ll give that a shot.

So even with “Skip Busy Agent” enabled… a call coming in that that extension is a member of a ring group still disrupts an occupied call. It doesn’t “ring” the phone… however, the BLF keys for other extensions (members of the ring group) light up.

Could the BLF keys be the problem?
Where the status updates (BLF lights) of each extension might be overloading the phone hardware?

Can you disable the stutter via the phone config?

I’m probably not using the correct term, what I mean is the call breaks up when another call comes in.
Stutter is actually already disabled in the phone config.

Additionally I found that when the ring group is a size of 1 or 2, the calls are fine. However when the ring group is larger than 2, the call will breakup when on an occupied call.

Also, even if a phone is not a member of the ring group, and that phone is on a call, the occupied call will breakup.

This is starting to make me think maybe BLF key updates to a ringing state are somehow to blame. I’m going to disable them temporarily and see if this has any difference.

well… It was the BLF keys! When I turned all my BLF keys to just Speed Dial keys… problem went away.

Not sure if my client is going to like that trade-off though…

Is there a way to either:

  • Disable the “ringing” status for BLF keys and only display “Available” or “Busy”?
  • Change the frequency of the BLF status lights to a less often?
  • Disable BLF status updates while a phone is occupied/“Busy”?

or any other ideas?

I’ve seen this on old Aastra 57i but only with sidecars. The solution was as you said use speed dial instead of blf.

oh man… so this a limitation of Aastra/Mitel hardware and not other phones?