Call Records Not Logging to DB

Hi All

I have a fresh install of FreePBX from the AsteriskNOW ISO.

I have it set up to the point that I have two extensions that can call each other.

I am specifically interested in logging calls to the DB but when I check the call logs page there are no calls recorded. doing a select on the asteriskcdrdb shows nothing too.

Some forum searching indicates that you need the asterisk-addons package for this feature.

So I do a yum install asterisk-addons

Oh no, I’ve hit DEPENDENCY HELL! Apparently asterisk-addons1.8 conflicts with the asterisk1.6 that is installed. Why is it trying to install 1.8? I don’t know. So, I look through the packages available and see that I can manually install asterisk-addons1.6 so I try that and reboot.

Unfortunately although this appeared to install, call records are still not logged.

Am I missing something here?

I have changed the default password (with some difficulty but I eventually got it right, I think)

SET PASSWORD FOR [email protected]=PASSWORD(‘newpassword’);

/etc/amportal.conf:

AMPDBPASS=newpassword

/etc/asterisk/cdr_mysql.conf:

password=newpassword

/etc/asterisk/extensions_additional.conf

AMPMGRPASS = newpassword
AMPDBPASS = newpassword

/etc/asterisk/manager.conf
secret = newpassword

Thanks in advance!

from a clean install I do not get CDR
CLI> cdr show status

Call Detail Record (CDR) settings

Logging: Enabled
Mode: Simple
Log unanswered calls: No

  • Registered Backends

    (none)

after a yum install asterisk-addons
i still get the error
Registered Backends

(none)

Hi A-Roby

Try uninstalling asterisk-addons and then;

yum install asterisk16 asterisk-addons16

That’s how I got mine working. I did restart from a fresh install though, if the above doesn’t work do a clean install and then try the yum command again.

Cheers
Brett

OK, I reverted to a fresh install with no changing of passwords. A complete vanilla install.

Call logging still does not work.

I did a yum remove of asterisk and then yum install asterisk18 and yum install asterisk-addons.

Both installed without problems.

However, I still have no call logging.

Am I missing something here? Should this just work out of the box or do I need to do something to enable logging?