Call Recordings link in ARI is non existent

I have searched the Internet in all existing forums about Call Recordings link in ARI interface and i haven’t come up with a working solution. I installed and setup Asterisk through AsteriskNOW 1.5.0b1 distro in a regular PC (Core2Duo, 1GB RAM, 2x500GB HDD in software RAID1 mode) with a Digium B410P Wildcard Quad BRI card and I used mISDN drivers. Asterisk works OK, FreePBX also seems to work OK, i have CDR entries in both Report and ARI interface (in which i can login OK either as Admin or a user) and i can see, in an existing extension, the recording files in the monitor folder. BUT i can’t make the link in the Monitor column to work. I recompiled the Asterisk addons with the UniqueId tweak, modified the main.conf.php file and changed the permissions in the monitor folder but with no effect.

I know many users have this problem but also many others don’t!!! What have they done more and they made it work? In Trixbox (i haven’t test it) they say that this feature works out of the box…

Does anybody have any idea…

Thanks in advance…

For the Call Monitor links to work, the recordings must be in the right place with the right file name.

Here is a simple way to check if the recordings are working.

  1. Use Module Admin page to make sure all your modules are up to date.
  2. Use General Settings page to set Extension Recording Override to Disabled, then Submit and Apply Updates.
  3. Log into ARI (NOT as admin, but as a regular extension).
  4. Use ARI Settings page to set Record INCOMING to Always and click Update.
  5. From another extension call the extension you just updated in step 4. Make sure that there is actual audio (not silence) for at least 10 seconds, then end the call.
  6. Use ARI Call Monitor page to check for the record of the call you just made. If there is a playback/download link in the Monitor column, your system is working correctly.
  7. If the Monitor column is blank, check /var/spool/asterisk/monitor for a file with a name like date-time-uniqueid.wav (i.e. 20090129-090813-121931665.244.wav) or INextension-date-time-uniqueid.wav (i.e. IN204-20090129-090813-121931665.244.wav). If neither of these files exist, something is wrong with the recording process.
  8. If you find the recording in /var/spool/asterisk/monitor, but the Monitor column is blank, make sure that the following line is set in recordings/includes/main.conf.php: $ASTERISK_CALLMONITOR_PATH = “/var/spool/asterisk/monitor”;

Let us know how it goes.

I installed PBX in a Flash instead of AsteriskNOW and now i am having Call Recordings working out of the box…

Thank you very much for your help in this matter…

  1. Upgraded all modules
  2. Set Extension Recording Override to Disabled
  3. Log into ARI using my own extension (not admin)
  4. Set Record Incoming and Outgoing to Always
  5. Called from my cell phone (as opposed to an external extension) and the call appeared as it should in the call monitor. Tried this from my desk phone to my cell, which also worked.
  6. Records of both called arrived in ARI as expected, but with nothing in the Monitor column.
  7. /var/spool/asterisk/monitor has wav files for each of the calls I have made in trying to test.
  8. main.conf.php is pointing to /var/spool/asterisk/monitor as you described.

Any other ideas? I’ve been futzing with this for a while, as one of my coworkers asked about the call-recording functionality today. Its something our old system had that I haven’t enabled on asterisk yet.

and have confirmed everything in the previous posts. Does anyone know what else I can try?

Did you ever get this resolved? im having the same issue as well. =(

I fought this problem for several months on two different machines (including ditching AsteriskNow and moving to Elastix on one of the machines).

The problem: by default the asterisk-addons-mysql (which speeds up getting CDRs into MySQL in the first place) is not configured (at least as of 1.4.10) to add the uniqueid column, which is what ARI uses to match the file.

Here is what I did to resolve it:

  1. “yum install asterisk-devel” (this also upgraded Asterisk 1.4.24 to 1.4.29- which seemed to work fine with FreePBX- I had also in the process upgraded from FreePBX 2.5 to 2.6)

  2. Downloaded the patched asterisk-addons-1.4.10 from this site: (site also has instructions on how to build it). You could also patch the file yourself with the directions from: (NOTE: In both cases I kept getting errors stating that it could not find asterisk.h and numerous other issues when I first tried to compile it. The key was getting that asterisk-devel package (or possibly upgrading to 1.4.29, but I am pretty sure it was the asterisk-devel package as it was missing the entire /usr/includes/asterisk directory before which kept crashing “make”).

  3. “amportal chown”

  4. “amportal restart”

The asteriskcdrdb.cdr table then had entries for uniqueid (in turn showing the option to play the file from within ARI).


I have asterisk 1.6 and free pbx 2.7 and not all the calls are getting able to be monitor by Free Pbx > Recordings > Call monitor

But if go to linux comand line I see all the call there???

Any one can help me with this issue please



I am also stuck in the same problem. The wav files are inside /var/spool/asterisk/monitor folder and main.conf.php is also pointing to this location but still the call monitor in ARI is blank.

Has anyone resolved this problem? I am using Asterisk 1.6 and Freepbx 2.7 and updated all the modules.