Call recording only on answer on extension/user


Is there a way to only record calls on answer by extension?
I’ve tried all kinds of different settings, but none of them work. Tried: inbound routes, queues, ring groups, extensions but it’s recording everything or nothing.

I have a few queues and ring groups, when a call comes in it starts recording after the IVR option or on different setting with the IVR and records until call ends. I’m not interested in what my callers say in hold, I only want the conversations between caller and extension.

In an older versions this was working fine, but it’s changed and now I got recordings of 8 minutes on hold music and 2 minutes of conversation. Which takes up a lot of unnecessary space…

Everything should be set to don’t care except for the extensions, which should be set to force or yes on incoming external calls

Thanks Rob,

Suggested solution is working for queues, but with the same setting calls to ring groups aren’t recorded.

Any ideas?

Hmm. That sounds like a bug. Are you sure you’ve got the latest ring groups module?

What version do you have?

I use the latest stable versions and Call recording is version:

Do you have a solution? I have the same problem.

FreePBX 12 with last updates.
In 2.11 i have option “Recording Mode -> After Answered”, but in freepbx 12 this option is not available. Why?

Because it changed :sunglasses: