Call Recording Log

When I log into user panel with either an extension number and the password or the admin and password, i click on call recordings on the left. when the page loads it shows a list of inbound outbound calls and the recording, if there is one. i click on select all and all the boxes on the screen are checked, and i hit delete. my questions…

  1. does it actually delete the wav file off the drive
  2. once i delete it, and refresh the page, the log is still there, just with no recordings… how to i delete the actual log so i show no incoming or outgoing calls in the log?


Asterisk (Ver. 11.2.1)
Using FreePBX

Tried to delete the extension that I want to clear the log for and recreate it and it doesnt work, logs are still there.

They are in the mysql datebase asteriskcdr table cdr, to delete all records :-

mysql -u user -ppassword -D asteriskcdrdb -e ‘delete from cdr’

i get an error command not found

I don’t. mysql is a critical part of FreePBX, how did you install your system?

And from where are you running that command?

from the iso image form the website here. i keep getting an error that root does not have access using password yes. i am running it directly from the terminal

not the same error, you probably don’t have a password yet set for the root account so leave out the -p thingy and think about adding one for enhanced security.

got in but all it shows is mysql> with a cursor

then you left out the -e bit and possibly the -D bit.

making progress… access denied for user ‘’@‘localhost’ to database ‘asteriskcdrdb’

now you left out the right user if you are rooot, then you can leave out the -u bit also, tjhere is always ‘man mysql’ and google if you care to learrn.

yeah tried google keep getting the same errors. i can log into mysql but it says that i dont have access to the database.

i wish there was a gui for all this!

take a look at phpmyadmin

there are dozens of gui interfaces to mysql, however every one will need you to know what your username and password are, phpmyadmin and the webmin interfaces are very suspect as to security, anything that has access to your root privileges through any well known port is dangerous, explore your apache logs for attempts againt phpmy* or port 10000 if you don’t believe me.