Call Queues with SIP Extensions - FIX HERE!


In order to get Call Queues to work with SIP extensions, I have to modify the /etc/asterisk/queues_additional.conf to change the member context as follows:

[code:1]member => SIP/313,0
member => SIP/312,0
member => SIP/311,0
member => SIP/113,0
member => SIP/112,0
member => SIP/111,0

The format that FreePBX inserts does not work and the callers get stuck in the queue.

I recommend making a change to the source code to make this work, as this is the correct format on all of the official Asterisk documentation.



In order to get Call Queues to work with SIP extensions…k[/quote]

It should work, as it works for everyone else! Why do you think that using Local channels is bad?



I posted a message asking about how to change the default behavior when an extension is busy , and with the change to the queues_additional.conf file, my freebox configuration was successfully…

I was said

When an local extension is busy, and it has other incoming call, that call is sent to the user’s voicemail. I would like to change that, sending the call to a queue, telling to the caller “that extension is busy, you can wait or press 1 to leave a message”.

I tried to do that, creating a queue which the only member is the extension was busy, also, I create an IVR menu using a recorded audio file, (telling the message “that extension is…”) and set up the opcion 1 to the voicemail, and “t” option to the queue created above.
Then, I returned to the queue configuration, and on the " Caller Announcements" settings, I selected the IVR with the message in “voice menu”, and “frequency” to “1 minute”. So, every minute you’ll hear the message and you could leave a message or continue waiting…

Now, Using the Feature code “foward on busy”, I set up my extension to forward to the queue number extension my calls when I be busy…but, the behavior is strange…the second incoming call doesn’t hear the ON HOLD music…and it only hear the message being playing over and over…

In the asterisk CLI I see as a “loop”…the second call enters and leaves the queue immediately …so, anyone can help me with some trick or advice?

In meantime i did the follow changes in file


The line 63

$members[$key] = “Local/”.$members[$key]."@from-internal/n,".$penalty_val;

I changed for

$members[$key] = “SIP/”.$members[$key].",".$penalty_val;

(I know, I’m considering only SIP extensions, no external numbers, no others channels types)

Then, in the same file, the follow lines

foreach ($member as $mem) {
$mem = rtrim(ltrim(strstr($mem,"/"),"/"),"@from-internal");
echo substr($mem,0,strpos($mem, “@”)).substr($mem,strrpos($mem, “,”)).“n”;

I changed for


foreach ($member as $mem) {
$reg = NULL;
if (ereg(’^[[alpha]]+/([[digit]]+,[[digit]])$’, $mem, $reg)) {
print $reg[1].“n”;
} else { print "NOT MATCH ANYTHING $memn "; }


I know that is an error not consider anything else, but this is in meantime…please consider the change on the member format in the queues_additionals.conf file as phpfreak described