Call pickup not working down the line

Hi, As the topic suggest im having a problem with call pickups. I’m currently running Asterisk 1.2.14 with Freepbx 2.3.0rc1 and GXP-2000 phones.

The problem is like this, i’ll try to explain but its kinda tricky.
Say i have a incomming call (we’ll name it A) to extension B, B blind transfers the call to C, but C isn’t around so B wants to pickup the call and notify them that C ain’t there…

When B tries to pickup he gets an error that says 603 on the GXP-2000. And this is my problem, after B transfers the call noone can pickup the call again. Only way to talk to the person is to answer C’s phone and then transfer or just keep the call on the line there.

What I’ve noticed thou is that if B calls A and decides that A needs to talk to C, and C isn’t answering then B but noone else can pickup the call.

I’ve tried putting every extension in a pickupgroup but i only get 503 errors on my phones when i try using *8.

My “show features” looks like this.
Builtin Feature Default Current

Pickup *8 *8
Blind Transfer # ##
Attended Transfer
One Touch Monitor *1
Disconnect Call * **

And i have no special configuration on my extension, its all Freepbx standard. The only thing they contain is a User Extension, Display Name, Secret and now the Pickupgroup=alla.

Is this a known error or does anyone have an idea how to resolv this matter?

Could it be something with the way GXP-2000/2020 works with transfering calls?

Or is it something with Freepbx/asterisk? My boss insisted that it used to work when we just had asterisk without Freepbx and had a homebrewed dialplan.

Please tell me if you need to know anything else, like config files or output from asterisk.

Fredrik Eriksson

I have no idea if this will help, but I have only seen pickupgroup as a number.

When I’ve tried it, it also seems to need callgroup set to the same value on the same extensions.

Thank you for your reply.

I tried changing pickupgroup to =1 and set callgroup=1 also. This helped abit.

I can now pickup a call thats been transfered by issueing *8, quick buttons on my GXP-2000 still doesnt work thou. But im guessing thats because Direct Pickup is used by the quick buttons and not grouppickup.

Something that i thought of when i tried this was if there’s anyway to use *8 and pickup on a certain extension?
Or if the ** function can be used in any way? (since the phones uses that)

Say if you have 2 incomming calls and i press *8, i will get the latest incomming call. This poses a problem since i might want to pickup the first call since its actually the one i was expecting.

Fredrik Eriksson

Sorry, I’ve not used it enough to know exactly how it works.

With more than one call, I’d expect it to pick up the first one, but I have no idea if that’s what actually happens.

I’ve been googling around abit and what i understand you should be able to use *8+ to pickup a call with grouppickup, but when i try to do it my asterisk tells me that this function is not available for this extension.

I’ve also tried using DPickup() instead of Pickup() since i read something about DPickup() is the new bristuff prefered way of handling Direct Pickups. This didn’t change anything thou, it still doesn’t do anything when i try to pickup the transfered call.

And i haven’t found anything that points in the direction that anyone else is having a similar problem :?

Fredrik Eriksson

Hi again all,

We now think we know what the issue is. We believe it doesn’t have anything to do with how asterisk or freepbx handles call pickups. This is probably a Grandstream problem. Their firmware supports the function to transfer calls w/o any help from the asterisk. So when using ## to transfer the call you can pickup anywhere and everything is glorious. But when pressing the “TRNF” button which is what we want the phone itself transfers the call to the said extension, asterisk isn’t involved more then making another call. You can pickup up this call, but you have to dial ** and not **.

So now we have an entirely diffrent problem :). Since we want to use the TRNF button and speeddial BLF.

Anyway, thx for your help. I’ll post a resolution if I find any or if it turns out we’re not on the right track.