Call Park - Single Button Using Dsskey

If you are using ##70# to park calls, the BLF key should show Call Park 71 and another with Call Park 72, etc. You need one park button for each slot you want to use. I don’t know what 11 is in your case. That gives you one-touch park and retrieve for each monitored slot.

If you have set up more than one parking lot, this suggestion may not apply.

Forget the ##70# that is the old way of doing things… This is a test phone. I have 2 keys setup because ‘Park Call’ does have some weird interactions with different settings on the phone. 11 is just a parking lot… Either of these buttons should park the call into that parking lot yes?

I do not have Yealink phones but on my phones, I use the BLF/Xfer keys and simply put the parking slot number. It works flawlessly on FreePBX 15 and FreePBX 16. I think in your case, using the call park button to put it in the slot may not work. Instead use the information in this manual for the Yealink regarding transfer via BLF/DSS. You simply put the parking slot (not parking lot) number on the key.

The Yealink T46 manual explains the use of the DSS key vs. the BLF key. Beyond that, I cannot understand why this is not working for you unless there is something obscure when you have more than one parking lot. I’ve never used multiple parking lots.

Correct, 11 is what you called a ‘slot’. I have 1 parking lot (10) with 5 slots starting with 11,12,13,etc…
There are others that have had issues with these phones not parking with BLF or Call Park selected.
Maybe its time to switch but I have one office with 30 of these things lol.

As popular as the T46 is, it is hard to imagine there isn’t a way to make it work. Perhaps someone with this phone will reply.

I can confirm that it works on Aastra, Grandstream GRP series and Fanvil phones.

What version of FreePBX are you running on your system and what firmware version is on your Yealink phones. This discussion in FreePBX seems to indicate there is an issue both with firmware version on the phones and also with older FreePBX versions. Apparently, FreePBX 16 solves the issue.

Also, you may have to put the parking slot extension 11 in the “Extension” field on the BLF key.

I opened this thread because that one said the issue was fixed in 16 and it closed… I am on Freepbx 16 and my firmware on the phone is It is the most recent from Yealink per their support site.

Well I am in the middle of the woods right now but when I get home I will post my configs. I do this with numerous locations and it works just fine having 1 touch park/pickup.

I appreciate any help I can get on this one, I am out of ideas and settings to try!

My reply in How to enable transfer DIRECTLY to parking SLOT - General Help - FreePBX Community Forums

EDIT Again, I’ve done too many threads for this. So there may have been a step missing here.

transfer.dsskey_deal_type = 2 << This is the real magic sauce here, I’ve said in other threads the DSS Key transfer mode must be Blind I thought that was already set in some of these but might not be.

Then it’s just: (I use 1-10 as my slot numbers instead of 71-79)

linekey.6.label = Line 1
linekey.6.line = 1
linekey.6.type = 16
linekey.6.value = 1

Hello @BlazeStudios,

Thanks for sharing the info. I still seem to be missing something.

I have disabled semi-attended transfer.

I believe I’m supposed to use BLF for the DSS Key config. In my case the users want to blind transfer a call to 1 of 3 defined parking spaces, they then tell others in the office where they put it.

I have asterisk setup with 70 for the parking lot extension and 3 slots starting at 75.

If I choose BLF, it seems I need to define a value and an extension on my T46s, I’m confused which values need to go in each of those fields. Appreciate any clarity you can share.


  1. Set Line Type to BLF
  2. Value = Parking Lot Slot
  3. Label = Display on the phone
  4. Line = The account to use (generally 1)
  5. Extension = I leave this blank

Thanks for the quick reply… That’s what I have so I seem to be missing something?

When I hit Park 1 from the phone, the call transfers but the light remains green and if I try to pick it up in that parked slot (hit that button again from the same phone or a different phone), it rings that extension (75 in my testing) and tells me no call is parked.

Just to confirm, you are hitting the Park 1 to park the call while the caller is still on the line?

At this point we would need to see a debug from the system to confirm the call is being parked. You’ll need to provide a call that you attempt to park but the button never changes.

Correct… I’m calling from my cell, I pick up, confirm there’s a connection, and then I hit Park 1 (should send them to 75). The “Park 1” light remains green, though the call transfers from that desk phone. My call is still active on my cell side, I am lost in the nether or upside down world. :slight_smile:

Let me track some logs, I just wanted to be sure I was configuring it correctly, which seems to be the case.

I am curious though… in FreePBX it tells me 70 is the park extension. I’ve set my lots to begin at 75 through 77. Is there some other value needing passed or is that encoded in the BLF function? Just wanted to make sure I wasn’t missing some other function.

I saw @sawgood1000 suggested using the new Park feature in the t46s, but the method you’ve outlined is how they are trained to use it today so I’d prefer to stick with that option if I can.

Let me do some logging.


Hello @BlazeStudios,

Here’s a log from my call, unless I’m mistaken (very possible), it doesn’t seem to be doing the transfer.

Now we need to see the export of the Yealink config. Call isn’t being parked.

@SacredKow Thanks for the sanity check, thought I was the only one having this problem. Mine is EXACTLY as you describe it. When you hit the button set up as a BLF, and blind transfer set nothing happens at the PBX level and when you hit the button again it tries to pick up that line with the default ‘sorry nobody there’ message…

Here is a pastebin of the T46G debug log at the moment I hit the transfer button

Here’s the config @BlazeStudios

I think we’re about to get it sorted out @Dellsmash - hopefully!


I’ve dealt with a few call park threads lately and I could have sworn in one of that I said “You cannot use FAC, Asterisk doesn’t support it.” The “Call Park” options are for a specific type of Call Parking that Asterisk doesn’t support. Thus have call_park.mode =1 (FAC) means you’re telling the phone to use the wrong mode.

Both of you need to make sure that is disabled and test again.